Play Store not working

Discussion in 'Xiaomi Mi 2A' started by Garwain, Oct 1, 2013.

  1. Garwain

    GarwainMembers

    Oct 1, 2013
    3
    0
    11
    Hello everyone,
    I have a problem, I just bought Mi2A few days ago and installed newest ROM from here (3.9.27). Everything works great except Play Store ... when i try to launch it it always says: No Connection.
    Even thought I have 3G connection.

    Any ideas ?

    Thanks a lot.
     
  2. Derek182

    Derek182Members

    Sep 12, 2013
    35
    2
    18
    Male
    Try to delete your Google account on mi2a and reconfigure it.

    Envoyé depuis mon MI 2A en utilisant Tapatalk 4
     
  3. Garwain

    GarwainMembers

    Oct 1, 2013
    3
    0
    11
    Thanks, i didnt find where to remove my account :) .. but i make a new one and still the same problem :(
     
  4. ArchNL

    ArchNLMembers

    Sep 26, 2013
    66
    7
    18
    Male
    Try to go to system settings, apps and find Google play services and wipe data here. Maybe that will fix the problem.

    Verstuurd van mijn MI 2A met Tapatalk
     
  5. Garwain

    GarwainMembers

    Oct 1, 2013
    3
    0
    11
    Yeah already try that and still the same. I try to manually instal new version but didnt help.
     
  6. Levani

    LevaniMembers

    Aug 6, 2013
    7
    0
    11
    Male
    Having the same problem... Anyone found a solution?
     
  7. thecryof

    thecryofMembers

    Aug 29, 2013
    109
    8
    28
    Male
    Belgium
    I sometimes get this message when trying to get Google Now updated. Annoying.
     

Share Our Site