popping noise while talking [Fixed]


Dec 14, 2013
21
0
11
#1
This Bug has been fixed with 3.12.20 rom build

Hello,
People on the other side of the phone have been telling me that there is noise with my voice. I then tried to record myself and it really is there.
I supose it's not a hardware problem since it does so with both phone mic and headset. But if I'm wrong then I'll have to send the phone back...
Here are the files of recording.
dropbox link

Has anyone had this problem yet? Is there a fix? I'm now using the multi lang 3.12.6 build ROM. phone is wcdma version
 
Last edited:
Nov 23, 2013
21
0
11
#4
I have the same problem and I've updated it right now to 3.12.13 and still does that noise >_<

I have Hongmi Red Rice WCDMA.
I've also tried recording my voice with headphones mic and it does the noise.
 
Dec 14, 2013
21
0
11
#5
After some more testing, I found out that the popping noise is coming from everything but the phone app.(also with BT headset) What I mean is, that if I use skype/viber/recorder, It does what i said before but while calling using a normal phone, my voice is clear. Same goes for the automatic phone recorder. Playing those back with clear sound.
 
Nov 23, 2013
21
0
11
#6
Yes, same for me. No one has complained when I make calls.
When I updated it, I didn't clear the cache and all that stuff because I don't wanna lose any data. Maybe that is why I haven't seen any difference with the update but the new security app.
 
Dec 16, 2013
18
0
11
#8
Hi, is updating to 3.12.13 or use older version fixed the issue?
yesterday i was able to receive call from my friend and using the video recording without any issue in afternoon. Suddenly at night halfway talking the other party can't hear me (using speaker)..keep trying but didn't notice the issue since that call is VOIP until this afternoon someone called me and got the same issue.
The issue also happen to video recording which the noise very bad.
I'm using built-in ROM from shipped (just used for 4 days). Can someone please help me?
 
Dec 16, 2013
18
0
11
#10
Where to see the version number? i only see JHBCNAH3.0
i just hear your popping noise and that could be different from mine although it may related. Mine is straight away hear static noise and voice can't hear.
 
Dec 14, 2013
21
0
11
#16
Yours might unfortunately be a phone mic. because you said that you dont even hear your voice and just static noise.

BTW first thing that came to my mind when i noticed this bug on my phone was "Is the noise cancelling mic bugging up or what?" because that popping noise can be heard only when i speak... then i spent 10 minutes trying to find the noise cancelling option to disable it. Is there a way to disable that mic?
 
Dec 16, 2013
18
0
11
#17
i couldn't find it either to play around with that
i guess i need to return it, not sure if just need to wait until it open store in Singapore so i can easily change here but i do read somewhere there still possible exchange 1 to 1 for less than 14 days or 7 days
 
Dec 14, 2013
21
0
11
#18
You should be fine since you haven't touched the rooting part. that's what could void your warranty. I t depends on the vendor though. my old lenovo phone was rooted since the start
 
Dec 18, 2013
4
0
11
#19
Hi, I have the same issue with my new hongmi. According to CPU Z and to the security code on the bottom of the box I have the genuine phone (bought on ********** :-/). I got the phone rooted from the seller and with preinstalled multilang MIUI 3.11.22. Although he seems to be a honest guy, I would prefer not sending the phone back to China.

Do you truly believe this is a software issue rather a hardware one? If so, I can live with the phone as it is now and wait for a future release of MIUI with this bug fixed. During a phone call the sound seems to be OK, and I can live without skype/video camera for now.

I will contact the seller anyway and ask for his oppinion on this problem. I will post if I get some interesting reply.
 
Dec 14, 2013
21
0
11
#20
I was ready to send my phone back until i tried the headset mic. And then i was sure it's not hardware bug, when i found out, that normal phonecalls work just fine.
Sml11's problem is different. The internal mic just outright doesn't work.
As for me, I'll wait until someone finds out what's wrong, tests my theory of the second mic or one of the future updates fixes it.
 
Dec 16, 2013
18
0
11
#22
how do you try/test the second mic?
anyone know what is the mic model/brand they used in case i need to repair locally here.
I tried to arrange ship back to China but the service application valid for 7 days only which not possible to reach there unless i pay the express one that will cost almost 1/3 of the phone's price without count the ship back to me again....
 
Dec 16, 2013
18
0
11
#23
wah...suddenly i test out again and the distorted sound gone...not sure what's happen, could be really a bug?
i will see how first and might think to buy Bluetooth headset in case issue come back
 
Dec 16, 2013
18
0
11
#24
upss sorry....i think it is still have problem.
1st test - sound record + video record no issue
2nd test - phone call got issue again
3rd test - sound record + video record got issue
4th test - sound record + video record no issue

Do you think is more on software bug issue?
 
Dec 18, 2013
4
0
11
#25
I just moved to the latest version of MIUI (also with english CWM) as described here: http://xiaomi.eu/community/threads/english-cwm-for-xiaomi-hongmi-td-wcdma-full-working.22953/

I'm happy to say the popping is gone. I tested it with Skype, video camera and phone call, and there was nothing. (Also another nasty bug I discovered yesterday was fixed - when I tried to dim the display in settings it switched off completely and I could not access the phone until I performed factory reset.)

A big thanks goes to the developers.