Problem after the replacement of the Display [Proximity sensor, camera focus]


Nov 10, 2014
3
1
13
#1
Hi to all, after the replacement of the Display of my Mi2S, i've the following problems:


- Proximity sensor don't work, i had to download a component of WSM tool to disable it


-In the camera, the focus of near objects don't work.




I have exposed my problems in a group of Italian XIaomi users, and other two users that had replaced display of mi2s, have the same identical problems.


Someone knows how can we fix these annoying problems?

Thank You,
Alfonso
 
Likes: ilkertr
Nov 23, 2013
584
167
80
#2
had same problem,for the proximity, simpli slide the finger in the top left side (where the sensor is) to activate it (i think that the new screen is a bad copy\replacement like mine). For the camera, i ve pressed a bit the sensor (until you hear a little "click")
 
Likes: Fonzy_84
Nov 10, 2014
3
1
13
#5
Ok...the most important things is the camera is done. i fixed it with the advice that you gave me, thank you a lot.
For the sensor, i prefer to leave it disabled.
Thank you again :)
 
Jun 8, 2013
161
20
30
#6
@Fonzy_84
I have the same issue with my proximity sensor after frame + lcd + touch replacement and i solved after weeks and weeks of google surfing :)
The problem is that the proximity sensor holder of the original frame doesn't work properly on an new frame so you must "manufacture" your own holder.
I use some iphone and samsung youtube videos to take some ideas and it work perfect now.
Maybe this video helps
 
Last edited:
Likes: novakt

Mleo

Members
Oct 19, 2013
47
6
18
#7
Good Morning gentlemen.
I also have these problems.
The camera does not focus closely, the notification LED does not work and the proximity sensor does not.
I'll try to do the above procedure for the sensor.
For the LED and the camera does anyone have any suggestions?
 

Mleo

Members
Oct 19, 2013
47
6
18
#8
Well, I tried the procedure described in the video, worked perfectly.
Now remained only little problems with the LED notifications and the camera.
I can do without notification LED, but accepted tips to fix the camera's focus.
Is there a video on the camera fix?
 
Jun 8, 2013
161
20
30
#9
Well, I tried the procedure described in the video, worked perfectly.
Now remained only little problems with the LED notifications and the camera.
I can do without notification LED, but accepted tips to fix the camera's focus.
Is there a video on the camera fix?
Nope nothing about camera, at last i dont see it. Led doesn't work at all? Or just the notifications?
I read some people complaining about the quality of some not originals frames + touch + digitalizers.
 

Mleo

Members
Oct 19, 2013
47
6
18
#10
Nope nothing about camera, at last i dont see it. Led doesn't work at all? Or just the notifications?
I read some people complaining about the quality of some not originals frames + touch + digitalizers.
The procedure that you indicated on the proximity sensor solved a big problem. I thank tips.
The problem with the camera is only focusing at close range.
But as work with precise electronic constantly shooting circuits and electronic components.
Tomorrow I will disassemble the unit again and try something with the cell phone on.
As for the LED, so far not tried to repair.
does not work absolutely nothing, I think that is problem with the same screen.
Sorry for bad english, google translator.
 
Sep 14, 2013
17
1
13
#11
hello,

I also come to change the screen of my MI2S, and I also had the problem of the focus of the camera, the solution is to be careful before putting the shell back, in the photo sensor housing is a protective rubber has removed and put on the sensor before reassembling the rear hull
 

Mleo

Members
Oct 19, 2013
47
6
18
#13
Problem solved. Working camera.
The rubber hood was actually inside the appliance
Thanks to those who helped with the tips
in the photo below gives to clearly see the rubber on the site where engages the camera module

camera.jpg suporte com a borracha.jpg
 

Mleo

Members
Oct 19, 2013
47
6
18
#15
Does anyone have any idea of how to proceed with LEDs?
LEDs are part of the screen or are on the mobo?
If part of the screen, I not have hopes of fixing
 
Jun 8, 2013
161
20
30
#16
Edited!!
Its part of the mobo!!

Great news about screen!

Does anyone have any idea of how to proceed with LEDs?
LEDs are part of the screen or are on the mobo?
If part of the screen, I not have hopes of fixing
The blank rectangle is where led contact from mobo to screen.

 
Last edited:
Likes: Mleo

Mleo

Members
Oct 19, 2013
47
6
18
#17
Thank U.
Tomorrow I will reopen my device, must have something blocking the light from the LED.
Probably should be an acrylic rectangle, and an anti-scratch protection should not have been removed
 

Mleo

Members
Oct 19, 2013
47
6
18
#18
Problem solved!
On the back of this white plastic piece, shown in the photo above, there is a small "hole". The glass in front of the screen is painted with black ink. the "little hole" was also painted.
Using the tip of a metal clips removed the painting. I mounted again and the LED works perfect.
Thanks to forum users my Mi2S is almost like new.
 

Mleo

Members
Oct 19, 2013
47
6
18
#20
good morning.
Yes, you must remove the rubber.
Before mounting the back cover again, put the rubber cover over the camera module
 
Sep 14, 2013
17
1
13
#24
The problem is, when you put the cover with the rubber, it was wrong. But if you put the rubber on the camera module before put the cover, everything is ok
 

Mleo

Members
Oct 19, 2013
47
6
18
#25
exactly.
If you mount the device without removing the rubber camera module socket, the distance between the lens and the glass will be higher.