Redmi 1s Not Charging

Discussion in 'Xiaomi Redmi 1S WCDMA' started by Thomas Fowler, Apr 8, 2016.

  1. Thomas Fowler

    Sep 29, 2015
    2
    0
    13
    Male
    I bought my phone in September 2014 from DrakoTech on Amazon. In September 2015 I had to get a new battery as the original one had stopped working. My phone is currently running an official English version of MIUI 7 (V7.1.1.0.KHCMICK) on Android 4.2. The problem started a week ago when my phone battery had completely run out so I put it to charge with my UGREEN charger (5V-1A) and Anker USB cable. There was no reaction at all from my phone so after leaving it plugged in for 10 hours I tried inserting a spare battery in the phone and it would charge if the battery wasn't totally dead. I noticed that my phone wasn't able to charge totally dead batteries but only batteries that had at least 1% battery. Yesterday my battery ran out and I inserted it in my phone and initially the LED started flashing as if it was going to turn on, but then the LED was of a constant red color that soon dimmed. The same would happen if I insert it in another Redmi 1S. The problem is that now, even with the spare battery, my phone will not charge. I have also tried with the original charger and the spare (original) battery but the phone won't respond at all or it will show the battery percentage without actually charging.Also both my mac and Windows computer will not read my phone, with or without battery.
    I am assuming that this is a charger port problem and a problem with the latest battery I bought.I live in Naples, Italy so I don't know of any official MIUI repair centers.
    Thanks for your time.
     
  2. dkoek

    dkoekMembers

    Jul 10, 2014
    19
    0
    11
    Male
  3. mezzaBS

    mezzaBSMembers

    Jun 30, 2016
    23
    7
    5
    Male
    find here
     
  4. Thomas Fowler

    Sep 29, 2015
    2
    0
    13
    Male
    Where?
     
  5. Alexiaomi

    AlexiaomiMembers

    Oct 28, 2014
    256
    26
    50
    Male
    Rotterdam, Netherlands
    Hello, i face the same problem now. Did you fix it?

    Alex
     

Share Our Site