Redmi 4 Pro Does Not Update


Dec 5, 2016
8
0
11
#1
Hello,
I just tried updating my redmi 4 pro to new 8.5.2.0 stable through the app "updater", but it doesent work, te smartphone restarts on the main screen of recovery.
I also tried to install it in recovery but an error has occurred and the installation has been blocked.
In my redmi is installed version 8.2.1.0 stable.

can someone help me?
 
Nov 23, 2016
101
4
30
#4
I am w/ the latest global rom v8.2.4.0 on my markw device.
İs it enuf to wipe only cache and dalvic Cache for TWRP flashing of the latest Eu rom v8.5.1.0. ??
 
Jul 22, 2015
21
15
15
#5
I am w/ the latest global rom v8.2.4.0 on my markw device.
İs it enuf to wipe only cache and dalvic Cache for TWRP flashing of the latest Eu rom v8.5.1.0. ??
Correct actions for installation:
1. If you’re flashing from one localized ROM to another (or Global rom to China), you must wipe every partition. Otherwise you’ll most probably stuck with some bugs and errors.
2. Before continue with this tutorial, make all required backups and save them to your PC or other device.
3. Boot into TWRP Custom Recovery.
4. In TWRP main menu select “Wipe” > “Advanced” > Select “Cache, Dalvik Cache, System, Data, Internal Storage” (Do not select other partitions!!!). Swipe to confirm.
5. After wipe is completed, you’ll see “Done” message, go back to TWRP main menu > Reboot > Reboot into recovery.
6. Your device will be completely clean, without any files.
7. Now connect your device to your PC and copy downloaded ROM .zip file for recovery.
8. Disconnect from PC.
9. Now go to “Install” and select ROM .zip file and swipe to confirm.
10. Wait until installation is completed. You should see “done” message.
11. Wipe “Cache” and “Dalvik”. Wait until “done” is appeared.
12. Reboot into system.
13. First startup will be longer than usual.
 
Likes: sas_sas
Nov 23, 2016
101
4
30
#6
I flashed (clean install thru TWRP) with the latest stable eu v8.5.1.0 rom (over global v8.2.4.0) but, Developer options settings is force closing..
Any solutions??.
 
Jul 22, 2015
21
15
15
#7
I flashed (clean install thru TWRP) with the latest stable eu v8.5.1.0 rom (over global v8.2.4.0) but, Developer options settings is force closing..
Any solutions??.
Hm. Try to choose a different system language. Often errors are due to this. Or try to reflash. No one had such a bug.
 
Likes: sas_sas
Nov 23, 2016
101
4
30
#8
@ brigudav,

I would like to ask something which bothers me too much..
Thanks in advance for your kind concern..

- my device, markw,
- unlocked officially,
- TWRP 3.0.3.0 installed,
- Not rooted.

Question;
If I do not flash 'lazyflasher-no-verity-opt-encrypt' after every TWRP rom flash (and fastboot flash too) it becomes softbrick after the next TWRP flashing.
Then, I am getting hard time and supposed to flash fastboot rom thru miflash tool due to I can enter only fastboot mode..
Of course after this, I have to start from the beginning and reflashing TWRP again etc etc...

İt makes me crayz..
Why happens like this?
What TWRP version is the best?
Pls suggest me...
 
Jul 22, 2015
21
15
15
#9
Likes: sas_sas