New Redmi Note 2 - Bluetooth Bug


Mar 2, 2016
23
1
15
#1
Hello,

My phone: Redmi Note 2 Prime, with "xiaomi.eu_multi_hermes_V7.2.3.0.LHMCNDA_v7-5.0.zip"

Bluetooth seems to be very buggy, some devices (Garmin Vifofit, Garmin Vivoactive HR, Garmin Edge 510, Bluetooth headset, an so on...) with a lot of other phones works like a charm, with bluetooth usb dongle on my pc, too, but with RN2 randomly disconnect, and I need to reboot and pair again.

Same bug with "xiaomi.eu_multi_hermes_V7.2.1.0.LHMCNDB_v7-5.0.zip" and previous 7.1 and 7.0

Can you help me?

Thank you very much!
 
Mar 18, 2016
18
2
15
#2
Some people say that is becouse of modem p51, Better is p37, you can see in settings, abaut phone which one you have.
There is link for p37, i flashed yesterday becouse of problem with mi band, viber notification stop comming-vibrating.
Other problem with bluetooth i dont have so maybe you can check this solution
 
Mar 2, 2016
23
1
15
#3
I found and succesfully tested a solution found here: (cannot post link)

1) download P37 here: (cannot post link)
2) reboot in TWRP
3) install above zip file as a rom
4) wipe cache and dalvik
5) reboot & enjoy :)

P.S.: sorry, I cannot post links, as I haven't sufficient reputation; ask me in PM ;)
 
Mar 18, 2016
18
2
15
#5
You can try app autostart and stay, which can do what name say....
My problem is mi band app and redmi note becouse phone kills app after some time and nobody out there dont have any solution
 
Mar 2, 2016
23
1
15
#6
Very bad.
My problem is with another brand similar to mi band and app, because RN2 kill app after some times, even if I set it to autostart, and even if I lock it!
But, even worse, when I manually reopen app, my it can't reconnect and sync, I have to redo sync process, association, and so on.
 
Mar 18, 2016
18
2
15
#10
Try p52 modem, maybe will help you, you have link somewhere here just search .
This is from Nikoz47, in rom Description he says bluetooth problem solved
I need more testing but i need to for now reconnect my mi band
 
Mar 2, 2016
23
1
15
#14
Hi guys, I tried in even ways...
1) last weekly and original modem or P37 or P52
2) last stable and original modem or P37 or P52

Nothing to do!

1) Allreli K6‎ with all combination: OK
2) Garmin Edge 510 with all combination: OK
3) Car headset with all combination: OK

The only devices with problem are Garmin fitness Band.
I noticed that all devices connect by bluetooth panel, and are listed as Bluetooth devices.
But fitness band no, I have to connect trought Garmin Connect Mobile App, and isn't listed under bluetooth device panel.

But, same band devices and same app, works like a charm on Motorola MotoG, various android 5.x Samsung, Vodafone Smart 4G and others; and, even in those cases, have to connect by Garmin Connect app.

Works like a charm even with iPad 2.

Only on RN2 the problem is: when i associate my Vivosmart through Garmin Connect app, it works, but, if I step away and are "out of range", when I return, there no way to reconnect. I have to redo pairing.

On all other phones, when I step away, and then return, Vivosmart automatically reconnect.

I do not know what to do :(:(:(:(:(:(
 
Mar 2, 2016
23
1
15
#17
Bad luck: same things.
I even noticed that's 6.5.19_v7-5.0 already has P37 inside...
I think it's a MIUI problem, that, after some times, kill or standby Garmin Connect Service (not APP).
Infact, if I reboot my phone and then don't open Garmin App, Garmin Service autostart and my EDGE 510 connect and sync.
As the "Phone" app: if I even kill "Phone" app, I continue receiving calls, because "Phone" services remains.
But, Garmin Connect Services, after sometimes, was killd and/or hybernated.
Another thing: EDGE 510 - Headset - Car audio - are all seen as bluetooth device, but Garmin Vivosmart HR don't: it has to be paired with Garmin Connect APP, and doesn't in BT devices list.

In few words: can I move Garmin Connect to System APP, as Phome, Contacts, Messages, etc.?
 
Oct 8, 2015
70
9
20
#18
I have a Garmin Vivoactive and this hack kinda works: when you lock the screen, make sure that the open app is Garmin Connect. I have the latest dev ROM and no modified modem driver. What is does not work for me: phone does not detect Vivoactive outside Garmin Connect app (even if I unpair and I search for it in Bluetooth devices, although BLE Scanner app sees it). Because of this, I cannot use automatic unlock of the phone.
 
Mar 18, 2016
18
2
15
#19
Stufo, ask this member how he do it....

itasoulas
Members
Michael_K said: ↑
Any news for us about Modem P52 ?

I have installed it a moment ago, and now I am waiting for finishing 1st boot (rebuilding dalvik, ....)
Hope it is worth the time trying it out. I will give feedback how it works with RN2/6.5.19.....
So far...
1. I think download speeds are a bit slower compared to P37 or P51, at least on Wifi (I don't know if baseband has to do with it anyway)
2. MiBand keeps loosing connection. Tried MiFit as system app and still the same
3. Wifi, data, gps work without issues

I am on latest xiaomi.eu stable on RN2 Hermes. Let me know also what are your findings especially on the 1st one cause it may be just my imagination. Or any other user using P52 modem. I read somewhere that Bluetooth on some devices maybe is a hardware issue on RN2 hence that
 
Oct 8, 2015
70
9
20
#20
I have latest dev ROM with default modem, I ditched the MiBand and use just Vivoactive. After giving Garmin Connect autostart and floating notifications permission, locked the app in the apps list and made sure power saving does not affect it, it is much more stable and connects most of the time to the Vivoactive.
 
Mar 2, 2016
23
1
15
#21
I have latest dev ROM with default modem, I ditched the MiBand and use just Vivoactive. After giving Garmin Connect autostart and floating notifications permission, locked the app in the apps list and made sure power saving does not affect it, it is much more stable and connects most of the time to the Vivoactive.
Same things, but only when Vivoactive and RN2 remains in bt range. On the First out of range, I have to reboot RN2 and pair again
 
Mar 2, 2016
23
1
15
#22
Same things, but only when Vivoactive and RN2 remains in bt range. On the First out of range, I have to reboot RN2 and pair again
Yesterday, during a call, by bt headset, about 1mt away from RN2, says "outof range". I have to disable and re-enable bt
 
Mar 2, 2016
23
1
15
#25
And, guys, finally I have to chuck in the sponge.

On RN2 with Helio X10, after dozens combination of roms, baseband, and so on, I still haven't found a single combination of 100% stable working bluetooth.

So I buyed RN3 Qualcomm, and... wow! I've tried some roms, official and not (now I have last xiaomi.eu weekly), and in all cases Bluetooth works like a charm.

It's possible some bug on Helio X10 BT stack?