Redmi Note 2 Prime Some Issues

Discussion in 'Xiaomi Redmi Note 2' started by Fulviov70, Apr 4, 2016.

  1. Fulviov70

    Fulviov70Members

    Mar 28, 2016
    10
    2
    13
    Hi everybody, i'm on 6.3.31 dev and got the following issues on my device. 1. Bluetooth connection is discontinuing
    2. After some time while listening to spotify and screen get off and device is locked, the music get stopped. Tried to lock the app (swipe down) but still not working
    3. Is the device rSAP compatible? Can connect to my car VW and have access to contact list but remote sim feature (premium ) is not available. Even the app on play store is not working.
    Thanks

    Inviato dal mio Redmi Note 2 utilizzando Tapatalk
     
  2. Michael_K

    Michael_KMembers

    Feb 3, 2016
    274
    288
    87
    Male
    Germany
    Confirm BT issue. Some hours ok, but most times unusable. Strange problems here with connection to pebble smart watch, jawbone UP24 and handfree talking in my car (VW). Some weeks ago I got a hint to go back to stable 7.0.6.0. I tried this and with this "old stable" BT was OK !
     
  3. Antonio70

    Antonio70Members

    Apr 5, 2016
    2
    0
    11
    Male
    Also me. I have the same problem with car BT and also with mi band. If you have any suggestion ...
    Thanks a lot !!!
     
  4. Holmis1984

    Holmis1984Members

    Mar 15, 2016
    5
    2
    13
    Male
    in the 7.2.1 stable ROM is BT ok!
     
    wasteyard likes this.
  5. Stefano131270

    Oct 4, 2015
    2,982
    1,659
    322
    Male
    Switzerland
    Try Mi Fit 2.0.5. apk
     
  6. David Bruun

    Jan 14, 2016
    48
    14
    18
    Male
    It's not a APK problem, but a software(driver for radio) problem in the ROM's, been there for the last 6 ROM updates, if you look up BlueTooth and GPS problems in bug rapports:mad:...
    I been very active in the forum and bug rapports...so i'm pretty sure about my case...
    I just received a OTA 7.2.3.0 LHMMIDA... hope that will fix some of the problems...
    And it don't help to do a full wipe and start over the phone all over again...tried that...did't fix the problem...

    Some says...that early ROM's didn't have this issue...but I tried to downgrade my phone to 6.1...and still had the problem...
    So lets hope it's not a hardware, build(CPU) problem...
     
  7. Michael_K

    Michael_KMembers

    Feb 3, 2016
    274
    288
    87
    Male
    Germany
    In my case BT issue had gone after downgrade to stable 7.0.6.0. (I am not the only one - got this hint in weekly thread)
    Nearly one week without the known randomly disconnections. Hands free talking in my car worked fine all day.
    After this 'testing period' I updated to weekly 6.3.3 and BT issues were back. In my opinion it is no problem of HW but problem of SW (modem driver?).
    So I hope xiaomi will fix this (known!!) BT issue in near future....

    BTW: Please can you give us feedback if new OTA 7.2.3.0 fixes BT (and/or GPS) issue? Thanks....
     
  8. Antonio70

    Antonio70Members

    Apr 5, 2016
    2
    0
    11
    Male
    Thanks a lot !! I think that the problem is on firmware or BT driver ! In the stable 7.2.1 seems works fine.
    but there is not a Italian language :(
     
  9. Fulviov70

    Fulviov70Members

    Mar 28, 2016
    10
    2
    13
    Thanks to everybody. Think would try a stable version hoping this will solve. In the meantime any solution for #2 with Spotify? It goes automatically on pause after ~10 min playing in Bluetooth or not. It looks like the system close the app.

    Inviato dal mio Redmi Note 2 utilizzando Tapatalk
     
  10. David Bruun

    Jan 14, 2016
    48
    14
    18
    Male
    7.2.3.0 Bluetooth drop out too...:mad:
    Tested for 3x walks 11.7km, 1H32m...2-3 drop-outs on every walk...tested with 3 different Bluetooth HS, S130, Bluedio HT , QCY QY8..all headsets are tested on a Sony Z1...with no problems. Distance between HS and Phone less than 50cm...
    MI band 1s...can't connect, close bluetooth, clean ram, open bluetooth...wait a minute..try and connect again...MI fit connects to MI band 1s...memory problem...
    looks like Xiaomi can't solve this...

    And 7.2.3.0 got the GPS logging problem...a problem from 7.2.2.0...
     
    Michael_K likes this.
  11. kicksomeazz

    Jan 24, 2016
    13
    2
    15
    Germany
    I have the same BT problems. It doesn't disconnect while being in BT use though (i.e. streaming music or talking with BT headset), but goes "offline" while in standby. When I use the car BT connection or want to use BT headset I recognize that BT connection cannot be established, though BT symbol is "active". When I try to switch BT off an on, it doesn't turn on and I have to restart the phone.

    With stable V7.0.8.0 and devs older than ~middle of december '15 I don't have these problems - always stable BT connection, no matter if in use or standby. That's why I use V7.0.8.0. Full wipe & clean installation of newest ROMs didn't help, by the way.
     
    Michael_K likes this.
  12. Michael_K

    Michael_KMembers

    Feb 3, 2016
    274
    288
    87
    Male
    Germany
    Yes, confirm. With old stable (I tried out 7.0.6.0) BT works fine. Stable 7.0.8.0 I did not try - so I can not say anything to that version.
    I will wait for next weekly. If BT remains unusable, I go back to stable 7.0.6.0. or 7.0.8.0.:(
     
  13. David Bruun

    Jan 14, 2016
    48
    14
    18
    Male
    IvanV wrote:
    "If you want your app to not lose GPS signal while screen is off, go to
    Settings\Additional Settings\Battery & performance\Manage apps' battery use\Choose apps\<Your app, e.g. Runtastic>
    and pick Allowed in the Background Location section...."

    I did all the suggestions from IvanV ...and after that..my MI band 1S connects "almost" every time...
    Endomondo, Google FIT, MI Band Tools, MI FIT, Navigator GPS program...set them to stay connected and allow location...
    Gonna test-walk today, 11.7KM to test bluetooth and GPS tracking...will return with result later...:)
     
    Fulviov70 likes this.
  14. David Bruun

    Jan 14, 2016
    48
    14
    18
    Male
    #14David Bruun,Apr 13, 2016
    Last edited: Apr 13, 2016
    Screenshot_2016-04-13-16-35-29_com.endomondo.android.png HAPPY:D
    For the first time in a very long and hard period of time, my GPS loggin started to work again, both in Endomomdo and Google FIT, thanks to IvanV The Great, even the MI band 1S is working on bluetooth...and only one drop out on the bluetooth headset...
    Seems that Xiaomi nerfed the settings a little to hard, to give better battery performance...but on behalf of the smartphone function, like bluetooth and GPS connections...

    How ever 2 hours of GPS logging and bluetooth headset use, 32% of battery drained..but it's a choice between working-out-smart and charge phone more...or not..I prefer smart...
     
  15. malyga

    malygaMembers

    Feb 17, 2016
    36
    23
    18
    Male
    Try also to install old modem v24.p37, it makes BT to work.
     
    Michael_K likes this.
  16. Michael_K

    Michael_KMembers

    Feb 3, 2016
    274
    288
    87
    Male
    Germany
    Did you only hear or read about this hint ? Or did you test it with your own RN2 and you can confirm that it works ?
    Do I have to reinstall this old modem every time after weekly update or only once ?
    You have any link for me where to get this old modem and how to install ? That would be fine... thank you in advance...
     
  17. malyga

    malygaMembers

    Feb 17, 2016
    36
    23
    18
    Male
    1. I have read about this solution on official miui bugtracker, there was link to spanish forum
    2. I have installed modem day-before-yesterday, it works good.
    3. I think, that we need to reinstall modem after each ROM update.
    4. I wrote howto in this thread: http://xiaomi.eu/community/threads/bluetooth-and-mi-band-issues.31026/#post-286821
     
    kicksomeazz and Michael_K like this.
  18. Michael_K

    Michael_KMembers

    Feb 3, 2016
    274
    288
    87
    Male
    Germany
    #18Michael_K,Apr 15, 2016
    Last edited: Apr 15, 2016
    Thank you very much - I will try it out !!

    EDIT: Installed without problems (done same way like rom installation). Now for about 4h NO(!) issues with BT. Last 4h stable without break in BT connection. I am surprised (positiv surprise!)
    Thank you @malyga for hint!
    @all: Try out, if your RN2 has issues with BT!!
     
  19. kicksomeazz

    Jan 24, 2016
    13
    2
    15
    Germany
    Michael and malyga, can you give us an update? Is your connection stable with old modem installation? I'm considering an update to current stable but hesitate due to possible BT instability...
     
  20. Michael_K

    Michael_KMembers

    Feb 3, 2016
    274
    288
    87
    Male
    Germany
    I am really satisfied with BT and P37 modem. Had no BT problem for about 3days! My pebble is connected 24h per day and talking with handsfree in my car was possible without any (BT) disconnects.
    Only WiFi at home broke down 2 or 3 times (only 0,1 kb/s data). Maybe P37 is reason for this. But WiFi off and on again, and all was ok.
    EDIT: RN2 Pro, 6.4.14 with P37 modem.
     
    kicksomeazz likes this.
  21. kicksomeazz

    Jan 24, 2016
    13
    2
    15
    Germany
    Thank you! Can you tell more about the Wifi breakdown? Does it solve the connection problem by itself or did you have to switch it off an on?
     
  22. Michael_K

    Michael_KMembers

    Feb 3, 2016
    274
    288
    87
    Male
    Germany
    After switching off Wifi, waiting few seconds and switching Wifi on again, normal speed was back. This was during day and while using phone. But I think the problem solves itself if you wait. I think so because during night, I got emails, the weather app updates, .... all over Wifi. And if Wifi connection would have not been reestablished by itself, I had to do it as first step in the morning. But Wifi was ok at this time.

    But try it for yourself. Do a full TWRP backup first, then install latest stable. If there are any BT and/or Wifi issues, you will see it after a short time. If so, you can install P37 modem, and if you are not satisfied, you can restore your old system. In my opinion no risk for you.
     
  23. kicksomeazz

    Jan 24, 2016
    13
    2
    15
    Germany
    Sounds good :) thank you!
     
  24. Michael_K

    Michael_KMembers

    Feb 3, 2016
    274
    288
    87
    Male
    Germany
    Just for information:
    I installed 6.4.21 this morning and P37 is still there. No overwriting of modem version with weekly update. No re-install of P37 necessary.
     
  25. Fulviov70

    Fulviov70Members

    Mar 28, 2016
    10
    2
    13
    Update - after some time with 14.4 looks like BT is now more stable and battery is improved. Let's see.
    Does anybody has any suggestion on rSAP? Think that this device is not fully compatible, tried also with the app on the play store but still not have the fully premium functionality on my VW system

    Inviato dal mio Redmi Note 2 utilizzando Tapatalk
     

Share Our Site