[ROM] AOKP 4.3 For Xiaomi mi2(S)!!!


Oct 14, 2013
26
2
13
#1
Just found this.. apparently the same guy who ported 4.2 AOKP just put out 4.3 yesterday. i will try it tomorrow.. too tired now.

Download: http://pan.baidu.com/s/1xJRDK

Just do the wipes and install

i am not sure if it will allow you to upgrade from preivous versions without any issues.. someone try and let us know..

Sources:
http://bbs.xiaomi.cn/forum.php?mod=viewthread&tid=8209431
http://www.kdfly.com/?p=73




DISCLAIMER
i am not a developer.. i just bought the device 2 days ago... found it and wanted to share..


(EDITED: the link was wrong, corrected it)
 
Last edited:
Likes: xeGox
Oct 14, 2013
26
2
13
#5
Hi,
have you flashed the ROM? If yes, can you please check and confirm that it is rooted, because I have serious doubts...
Thanks
I have the 4.2.2 version of the same rom, and it's rooted... I will flash it in a few hours busy right now but I am 100% positive it'll be rooted
 
Likes: treiliert
Jan 14, 2013
285
82
50
#10
what kind of audio bug? and how did you flash it?
this bug causes the sound to stop after the first three seconds of video recording.
The way I flashed it was the standard one using ClockWorkMod:
1. I wiped data/did factory reset
2 wiped cache
3 wiped dalvic cache (find it under advanced)
4. selected "install zip from sdcard" and then selected the ROM I had already copied to the root of the device's internal memory
5. after the installation of the ROM and before anything else I installed Gapps in the same way described in point 4
6. I went back and selected reboot now
7. in the next screen asking to fix root etc. I just selected Go back (the choice at the bottom of the list)
I faced no problem in flashing the ROM. But the reason I changed my previous daily ROM, LOSP, was exactly the same bug. Now, I flashed the last update of MoKee and I don't have this problem any longer. If you have any other question, just ask it...
 
Oct 14, 2013
26
2
13
#11
Cool.. Can you link me to these roms you're talking about... I am new to xiaomi MI 2 bought it 3 days ago coming from Samsung s2 so don't know much about the Dev scene old plus no thread on xda and the normal forums
 
Jan 14, 2013
285
82
50
#12
Cool.. Can you link me to these roms you're talking about... I am new to xiaomi MI 2 bought it 3 days ago coming from Samsung s2 so don't know much about the Dev scene old plus no thread on xda and the normal forums

Below is the thread of the ROM I’m using right now, MoKee, which doesn’t have the 3sec audio bug:

http://xiaomi.eu/community/threads/mokee-4-3-rc1-by-love_dcp.22374/

and here is the thread of the ROM I had before flashing AOKP, LOSP. To me, this is one of the best available 4.3 ROMs in this forum in terms of battery life, pre-installed applications and appearance tweaks.

http://xiaomi.eu/community/threads/losp-v3-10-05-mi1-1s-2-2s-latest.22070/

But I consider functionality as more important than anything else. So, MoKee for now, which isn’t bad at all.
 
Oct 14, 2013
26
2
13
#13
this bug causes the sound to stop after the first three seconds of video recording.
did you happend to know if the problem still persists on a third party camera app?
i don't really record much video anyways.. :p

Below is the thread of the ROM I’m using right now, MoKee, which doesn’t have the 3sec audio bug:

http://xiaomi.eu/community/threads/mokee-4-3-rc1-by-love_dcp.22374/

and here is the thread of the ROM I had before flashing AOKP, LOSP. To me, this is one of the best available 4.3 ROMs in this forum in terms of battery life, pre-installed applications and appearance tweaks.

http://xiaomi.eu/community/threads/losp-v3-10-05-mi1-1s-2-2s-latest.22070/

But I consider functionality as more important than anything else. So, MoKee for now, which isn’t bad at all.
thanks for info.. also do you happen to know how to revert to factory rom and factory recovery incase i have to give the phone in warranty?
 
Jan 14, 2013
285
82
50
#14
did you happend to know if the problem still persists on a third party camera app?
i don't really record much video anyways.. :p



thanks for info.. also do you happen to know how to revert to factory rom and factory recovery incase i have to give the phone in warranty?
no, I didn't try any third party camera app. As soon as I noticed the problem I installed directly the next ROM as a way to face the issue.
to revert to factory rom and recovery use miflash to flash the rom which was on the device when you bought it. For more details, check the thread below.

http://xiaomi.eu/community/threads/guide-flashing-rom-using-miflash.19287/