SD-Card Crash... forced wipe all.. someone got this ?


Mar 4, 2012
39
1
28
#1
Hi,

Yesterday was about just to upload on my sdcard some background by USB

My SDCard had 2 partitions . 1 ext3 for A2SD+ 1GB and 1 FAT32...
all was working like a charm since 2.3.9 version MiUI first time I installed.

I put many application and used as USB disk couple of time my phone without any issue...

but this night *(yesterday)
- plug my phone
- turn USB disk on
- about to send to USB disk
- Send... and nothing happen... like no copy, waiting waiting waiting...

so I unplugged my phone like I do always...
and my phone was hang.... no response...
have to remove the battery

restart the phone...
stuck on the Android loading page... and nothing more

After investigation, Without the sdcard, phone boot possible, without impossible...


is anyone got this problem ?


- I checked my sdcard with tools h2... no error.
- created my partition with linux since the phone not accept this sdcard... nothing phone wont accept the card anymore

I run now NO A2SD partition, on another SDCARD... and my old sdcard is in my camera... run perfectly.


please let me know if you ever had this issue, MIUI or SDCARD or else related... just need to understand
 
Dec 10, 2011
57
1
18
#2
had happened to me quite a few times, had looked on the net
somewhere said something bout an Android mmc writing er ror to sd, happened when i switched from 2gb class four to 32gb class ten. After applying this, no more problems three months +. this is my dropbox links, one is the fix = http://db.tt/9iNDJxSF and the other is to undo the fix = http://db.tt/IzVPps0H.
Hopes this helps
Moto defy mb525 latest version
 
Mar 4, 2012
39
1
28
#7
thanks,

you know what...
my 8GB crashed totally today... can't format it, windows want format only 1GB
my camera can't format (low format) stuck and crash...

R.I.P. 8GB... have to buy a new one, asap I got some money...
 
Dec 10, 2011
57
1
18
#8
Nah, try the format in windows regardless of what it says, when u put it back in the phone, format again. if it works, do a nandroid and than try flashing that zip. C if that works
 
Mar 4, 2012
39
1
28
#9
I will not try again, I got my 4GB inside my phone, and not in mood to redo all the installations lol

but my card is really dead for good.. probably a bad one.