SGS2 3.5.2 Can't turn off MTP mode?


Mar 22, 2012
41
2
18
#1
Sorry if this is a noobtard question, but how do I disable Media Transfer mode?

I just flashed 3.5.2 on my SGS2 i9100, and when I plug in to computer it launches MTP mode ("connected as a media device") automatically. I use the notifications screen to bring up the USB computer connection menu settings, and MTP mode has a switch but it won't switch off.

Is this a bug in this release, or am I missing something? It was working fine in the non-Samsung base release a couple of weeks ago.
 
Mar 22, 2012
41
2
18
#2
BTW - I think this is causing some serious battery drain.

I use the phone at work as an mp3 player, but there's no mobile reception at my desk so I have to run in flight mode to avoid battery being sucked dry by repeated network connect attempts. Normally plugged in via USB I can charge phone to 100% while playing music. But not since upgrade to 3.5.2. The MTP mode makes the phone hot and battery goes down faster than the charging by usb.

This may be a bug, but I posted here in case it was just a setting I can't find. Feel free to move post.
 
Likes: d4v3
Mar 22, 2012
41
2
18
#3
Actually, problem solved!

I was looking in STweaks* and in there I found an option under the Misc tab for USB Mass Storage Mode.
Changed this to Force Mass Storage Mode - and that's allowed me to switch off the MTP mode under the "USB computer connection" menu (which I can only get to when there is a usb cable connected).

It didn't seem to make a difference - and then I rebooted phone and ta daaaa - USB Storage back the way I want it. Huzzah.

* - looks like MIUI 3.5.2 comes with Siyah kernel, which I've never used before, and so had no idea what STweaks was!

PS - thanks for all your excellent work bringing us MIUI each week. Huge appreciation.
 
Likes: d4v3