Site security


Iain_B

Members
Mar 25, 2013
1,566
297
Rather frequently (several times a day) my connection to this site goes - 'Secure connection failed'. It only seems to be this site - all other sites seem to be alright. Also, the site seems to load with my data connection. The problem only seems to be over broadband. I use Firefox.
I have been onto my service provider who confirms that it could be a security issue with the site.

Any suggestions, or solutions?
 

Iain_B

Members
Mar 25, 2013
1,566
297
Rather frequently (several times a day) my connection to this site goes - 'Secure connection failed'. It only seems to be this site - all other sites seem to be alright. Also, the site seems to load with my data connection. The problem only seems to be over broadband. I use Firefox.
I have been onto my service provider who confirms that it could be a security issue with the site.

Any suggestions, or solutions?
Are there any issues with the site that could be causing this?
 

Iain_B

Members
Mar 25, 2013
1,566
297
Are there any issues with the site that could be causing this?
I have again been in touch with my ISP - BT (British Telecom, in the UK).
They are suggesting that it is from the xiaomi.eu / this website end, and that maybe some of the BT IPs are being blocked, possibly by the service provider this (xiaomi.eu's) end. All I know is that the connection goes several times a day, and it is quite annoying!!

I am just wondering if anyone can throw any light on it, and whether it is happening to anyone else.
 

Poney70

Donator
Oct 3, 2019
5,471
337
Hello!

When it happens, I'm willing to help and diagnostic/resolve your issue via TeamViewer (remote control software). ;)

Send me a PM if it's ok for you. :)