Solution for USB Ethernet Devices Mi Box 3 Intl.... [needs testing]


Status
Not open for further replies.

MarkHUK

Founder of Xiaomi.eu
Staff member
Nov 6, 2010
4,833
2,931
1,000,000
#1
For users with USB Ethernet issues please check if ADB debug is enabled, if it is, turn it off and try your USB Ethernet device again.

Please post your feedback here.
 
Likes: dankexi
Aug 15, 2017
12
1
15
#3
That's how it worked in Marsallow and Nougat.... and it still works like this in Oreo.

I have a UGreen USB 3 Ethernet adapter and it has never worked when USB debugging is enabled.
 

MarkHUK

Founder of Xiaomi.eu
Staff member
Nov 6, 2010
4,833
2,931
1,000,000
#5
That's how it worked in Marsallow and Nougat.... and it still works like this in Oreo.

I have a UGreen USB 3 Ethernet adapter and it has never worked when USB debugging is enabled.
yea, its the way it should react as well when debug is on.
 
Jul 9, 2018
2
1
5
#16
On Android 6.0.1 I was running Ethernet via USB hub ( i-tec USB 3.0 Metal 3-port HUB with Gigabit Ethernet adapter).After upgranding to Oreo, Mi Box can not see The Lan network. ADB debug is desabled. Wifi cuts.
 
Likes: leonce
Jul 7, 2018
28
6
10
#17
On Android 6.0.1 I was running Ethernet via USB hub ( i-tec USB 3.0 Metal 3-port HUB with Gigabit Ethernet adapter).After upgranding to Oreo, Mi Box can not see The Lan network. ADB debug is desabled. Wifi cuts.
IP parameters, use DHCP, not Static. Static doesn't work since Oreo
Otherwise your USB / RJ45 adapter is no longer recognized with the Oreo version, known bug.
What is the brand?
 
Jul 11, 2018
1
0
3
#19
My USB ethernet adapter is found by Mi Box, but the speed is terrible, around 5/6Mb on a gigabit connection (and a 200Mbps internet connection).
 
Last edited:
Status
Not open for further replies.