[SOLVED] MHL (HDMI) problem


5ulo

Members
May 25, 2012
135
15
28
#1
Has anyone tried HDMI thru MHL (USB) connector? Tried it on Galaxy Nexus with miui.us and Samsung Note and it worked. Then I tried my Xiaomi M2 with miuiandroid.com rom. TV has detected, that there is something connected but with message NO SIGNAL. Tried it also on second TV.
 
Feb 1, 2012
45
4
18
#2
I tried this the other evening using latest rom from this forum and it worked great. Note that the MHL adaptor for galaxy III is using a different standard. I bought a cheap adaptor and it worked fine. Hope xiaomi releases an official adaptor.

Sent from my MI 2 using Tapatalk 2
 

5ulo

Members
May 25, 2012
135
15
28
#4
Flashed JLB10 and it was working. Then flashed 3.1.11 back and.. voila.. it was maybe a kind of bug in my configuration or what..
 
Likes: Kees Podt

10-80

Members
Mar 4, 2012
91
2
18
#5
Just received a budget mhl adapter from ebay.
Works perfect on my PC monitor (ASUS VH242H) but not at all on my LCD TV (Sony KDL-46W5500).
When connected to the TV, the phone and TV both seem to know there's something connected - TV indicates "Stereo" and sound output from the phone's speaker stops but I get a blank screen and no sound on the TV.

I guess this TV is just not compatible with the mhl signal converted to HDMI that it's receiving.
 
Feb 1, 2012
45
4
18
#6
I have a cheap MHL adaptor and it works great on my MI2. Only problem is that subtitles disappear on some sites/apps

Sent from my MI 2 using Tapatalk 2
 
Jan 18, 2014
7
0
13
#7
I have a cheap MHL adaptor and it works great on my MI2. Only problem is that subtitles disappear on some sites/apps

Sent from my MI 2 using Tapatalk 2
About subtitles, I found that on MXplayer you have to choose sw decoding, in order to see the subtitles.
 
Jan 10, 2014
42
12
20
#8
Flashed JLB10 and it was working. Then flashed 3.1.11 back and.. voila.. it was maybe a kind of bug in my configuration or what..
Currently, the hdmi output signal from the MHL adapter (which is connected to my Hongmi Red Rice) is not recognised by my television.
Can you please share the two links to the exact JLB10 and the 3.1.11 ROMs you have used to make it work? I would like it very much if I could use my MHL hdmi adapter with my Hongmi :).
 
Last edited: