New [solved] VoLTE not working on davinci...and how I won the war!


giodeluigi

Members
Oct 2, 2019
230
52
No more VoLTE here on latest v12.1.1 stable.
Tried the code *#*#86583#*#* and now I see VoLTE switch that is turned to ON but everytime I start a call, I lose data connection.
Any solution to this?
Thank you
 

Alvy200

Members
Jan 30, 2021
286
52
No more VoLTE here on latest v12.1.1 stable.
Tried the code *#*#86583#*#* and now I see VoLTE switch that is turned to ON but everytime I start a call, I lose data connection.
Any solution to this?
Thank you
Upgrade to beta (or try to change dialer app. if this works, reset apn settings and remove and insert simcard after wiping cache in teamwin)

Sent from my M2007J3SG using Tapatalk
 
  • Like
Reactions: giodeluigi

giodeluigi

Members
Oct 2, 2019
230
52
Upgrade to beta (or try to change dialer app. if this works, reset apn settings and remove and insert simcard after wiping cache in teamwin)

Thanks for your answer.
Tried everything you wrote but nothing changed.
 

giodeluigi

Members
Oct 2, 2019
230
52
I think I did any possible test (sim/phone change, sim slot change, clean cache, switch ON/OFF VoLTE via dialer code) and I can confirm that VoLTE/HD Call is not working anymore on this first A11 stable build for Mi9T.
 

Igor Eisberg

Lead Developer
Staff member
Oct 6, 2016
7,628
322
Repeating the complaint is not going to solve it any faster. We don't have control over modem configurations.
 

giodeluigi

Members
Oct 2, 2019
230
52
I say sorry but neither an answer like yours helps.
Isn't this a forum about experiences and efforts sharing?
It could have been a problem with the Vodafone Italy network but going by exclusion I can say that the problem is within the rom.
I think that these lines could help other users having the same problems that I have and let them save them some time.
 

Igor Eisberg

Lead Developer
Staff member
Oct 6, 2016
7,628
322
I say sorry but neither an answer like yours helps.
Isn't this a forum about experiences and efforts sharing?
It could have been a problem with the Vodafone Italy network but going by exclusion I can say that the problem is within the rom.
I think that these lines could help other users having the same problems that I have and let them save them some time.
What you're doing is bumping your post, something that's not acceptable.
Your issue has been heard, if you want to maximize VoLTE compatibility, you may want to use an older Global ROM, not a China ROM-based one.
Like I said, we have no control over modem configuration that comes with the ROM, so saying "the problem is within the rom" ain't going to change that fact, even if it's true.
 

giodeluigi

Members
Oct 2, 2019
230
52
One year ago, more or less, many other users and I had the same problem but under A10 was solved following this:

Open Modem test tools by using *#*#663368378#*#* code in dialer > Open MBN config loading and activing tool > select mbn_eea.txt for SW MBN > tap on validate > wait some secs for update.

Unfortunately now, on A11, this doesn't seem to work anymore because if you try to run Modem Test Tools it simply doesn't start.
Do you (or any other other user) if there is any other way to manually change MBN config?
Thank you
 
  • Like
Reactions: Birraque

Igor Eisberg

Lead Developer
Staff member
Oct 6, 2016
7,628
322
One year ago, more or less, many other users and I had the same problem but under A10 was solved following this:

Open Modem test tools by using *#*#663368378#*#* code in dialer > Open MBN config loading and activing tool > select mbn_eea.txt for SW MBN > tap on validate > wait some secs for update.

Unfortunately now, on A11, this doesn't seem to work anymore because if you try to run Modem Test Tools it simply doesn't start.
Do you (or any other other user) if there is any other way to manually change MBN config?
Thank you
Use a recent Weekly then. Modem test tools are available since Weekly 20.12.28 on davinci, not before that, and not on Stable.
 
  • Like
Reactions: giodeluigi

giodeluigi

Members
Oct 2, 2019
230
52
[SOLUTION]

After more than 20 days...I did it and I tell you how:

I wasn't able to find any way to manually edit modem settings in Stable rom so I switched to Weekly which allows you to run Modem Test Tools.
This is what I did:

Open Modem test tools by using *#*#663368378#*#* code in dialer > Open MBN config loading and activing tool > select eu/vodafone/volte/italy/mcfg_sw.mbn (in my case) for SW MBN > tap on validate > wait some secs for update.

Success!
A never-seen-before VoLTE icon appeared at right top and it perfectly works.
How this could help any other user living the same nightmare.
 
  • Like
Reactions: albertosky86

Igor Eisberg

Lead Developer
Staff member
Oct 6, 2016
7,628
322
[SOLUTION]

After more than 20 days...I did it and I tell you how:

I wasn't able to find any way to manually edit modem settings in Stable rom so I switched to Weekly which allows you to run Modem Test Tools.
This is what I did:

Open Modem test tools by using *#*#663368378#*#* code in dialer > Open MBN config loading and activing tool > select eu/vodafone/volte/italy/mcfg_sw.mbn (in my case) for SW MBN > tap on validate > wait some secs for update.

Success!
A never-seen-before VoLTE icon appeared at right top and it perfectly works.
How this could help any other user living the same nightmare.
This is definitely a known workaround, but MBN is supposed to auto-switch according to the relevant operator ID.
davinci doesn't have separate MBN lists (i.e. mbn_global.txt, mbn_eea.txt, oem_sw.txt), it only has the default oem_sw.txt which has "mcfg_sw/generic/eu/vodafone/volte/italy/mcfg_sw.mbn" already listed. The real question is why it doesn't auto-switch to it...
 

giodeluigi

Members
Oct 2, 2019
230
52
This is definitely a known workaround, but MBN is supposed to auto-switch according to the relevant operator ID.
davinci doesn't have separate MBN lists (i.e. mbn_global.txt, mbn_eea.txt, oem_sw.txt), it only has the default oem_sw.txt which has "mcfg_sw/generic/eu/vodafone/volte/italy/mcfg_sw.mbn" already listed. The real question is why it doesn't auto-switch to it...
This remains a mystery to me also.
Before switching to Weekly I reinstalled previous davinci 12.0.6.0 Stable and I can confirm that VoLTE was perfectly working.
This doesn't happen in current 12.1.1.
When a new Stable will be out I try it to test this VoLTE thing.
 
  • Like
Reactions: Birraque

giodeluigi

Members
Oct 2, 2019
230
52
This is definitely a known workaround, but MBN is supposed to auto-switch according to the relevant operator ID.
davinci doesn't have separate MBN lists (i.e. mbn_global.txt, mbn_eea.txt, oem_sw.txt), it only has the default oem_sw.txt which has "mcfg_sw/generic/eu/vodafone/volte/italy/mcfg_sw.mbn" already listed. The real question is why it doesn't auto-switch to it...
The other problem is that on Stable there's no way to manually set it or am I wrong?
 

albertosky86

Members
Dec 15, 2020
5
15
Hello guys, hello @giodeluigi . I'm trying to follow your steps, but actually the attached image is what I see on my k30 5g A12 weekly.
In the listed SW MBM I only find: default, oem_sw.txt, oem_sw_j9.txt.
Do I have to search for "vodafone/VoLTE/Italy", (even if my operator is another one?) and then press "act"? And what then?
Thank you
 

Attachments

  • Screenshot_2021-04-07-23-20-55-275_com.xiaomi.mtb_2.jpg
    Screenshot_2021-04-07-23-20-55-275_com.xiaomi.mtb_2.jpg
    171.4 KB · Views: 432

giodeluigi

Members
Oct 2, 2019
230
52
Hello guys, hello @giodeluigi . I'm trying to follow your steps, but actually the attached image is what I see on my k30 5g A12 weekly.
In the listed SW MBM I only find: default, oem_sw.txt, oem_sw_j9.txt.
Do I have to search for "vodafone/VoLTE/Italy", (even if my operator is another one?) and then press "act"? And what then?
Thank you
Hi!
You'd better search your operator one.
 

mackaq76

Members
Nov 13, 2020
9
15
Volte worked android 10 but not 11 - the telstra mbn wont stick on SW mbn mbn_eaa.txt when I validate or make it def mbn.
I tried it global - it sticks but still have no volte.
Does anyone know how to disable automcfg?
Any ideas? Don't really want to back to A10 but need volte.

Does anyone know where to get Android 11 mbns? from another firmware?
I'm using Poco F2 Pro.
 

draxx

Members
May 27, 2022
8
15
Hi, this thread is very interesting.

Is a workaround to solve "volte" issue on stable xiaomi.eu version? I am using the 12.5.2 and the code does work obviously....
 

giodeluigi

Members
Oct 2, 2019
230
52
Hi, this thread is very interesting.

Is a workaround to solve "volte" issue on stable xiaomi.eu version? I am using the 12.5.2 and the code does work obviously....
Hi, solution is here:
https://xiaomi.eu/community/threads...vinci-and-how-i-won-the-war.60245/post-597515
There's no way AFAIK to solve VoLTE issue on Stable because of the lack of MBN config access.
If you set this on Weekly then format and switch to Stable you'll keep the previous (right and working) selected modem but no way to switch it again on Stable.
 
  • Like
Reactions: Birraque

draxx

Members
May 27, 2022
8
15
After several tests, I succeed to enable volte on ly phone keeping data fusion a phone call.

I just used the following codes :
*#*#86583#*#*
*#*#869434#*#*

Each should raise '.... Disabled'.

I rebooted the phone and now it works on 12.5 and sosh french operator.
 

gogocar62

Members
Apr 22, 2021
1,657
297
I've tried everything to solve this problem (VOLTE) on VIVO (Brazil), but nothing works; only for TIM.
 
  • Like
Reactions: Birraque