[Stable version 11.0.8] Screen orientation on flat surface


Slaay

Members
Jun 3, 2017
10
15
I've installed the latest version of Xiaomi.eu ROM on my Redmi Note 9S. When I put my phone on a flat surface for example a table and turn the screen on the home screen is showed.
When I open an application for example Gmail or camera app the apps are showed with the landscape orientation. When I lift up the phone, only the side of the front/rear camera, the apps get back to portrait mode.

I've installed the application Accelerometer Calibration and the app shows me the sensor inside my phone works ok, because the red dot is exactly in the middle. When the phone is laying on the table. When moving the phone the red dot also moves correctly.

Is there something else I can fix so apps will be opened in portraitmode when the phone is laying on a flat surface? Or is it a bug in the ROM? Or maybe a faulty device?
 

Attachments

  • Screenshot_2020-05-25-21-21-42-321_redpi.apps.accelerometercalibrationfree.jpg
    23.8 KB · Views: 193

LOLO9393

Members
Feb 8, 2016
3,210
322
I've installed the latest version of Xiaomi.eu ROM on my Redmi Note 9S. When I put my phone on a flat surface for example a table and turn the screen on the home screen is showed.
When I open an application for example Gmail or camera app the apps are showed with the landscape orientation. When I lift up the phone, only the side of the front/rear camera, the apps get back to portrait mode.

I've installed the application Accelerometer Calibration and the app shows me the sensor inside my phone works ok, because the red dot is exactly in the middle. When the phone is laying on the table. When moving the phone the red dot also moves correctly.

Is there something else I can fix so apps will be opened in portraitmode when the phone is laying on a flat surface? Or is it a bug in the ROM? Or maybe a faulty device?
it seems you have "rotate off" OFF.
Enable it in quick setting tab.
 

Slaay

Members
Jun 3, 2017
10
15
it seems you have "rotate off" OFF.
Enable it in quick setting tab.
The auto rotate function is enabled, when you disable it, you only get the portrait mode.
So badly that's not the solution for my problem.

//contacted Amazon: The device is not working correctly so I have to sent it back for a refund.
 
Last edited: