Invalid Theme compatibility Poco f3


MarcBear

Members
Aug 20, 2021
15
5
Since I updated to xiaomi.eu rom for my poco f3 12.5.5 all my themes that I downloaded so far have a compatibility issue. I cant apply any dialer, sms or status bar different than the standard one. In the whole theme store there is no single theme that can be fully applied. I started a similar thread a few days ago but any "solution" for this was that the theme designers have to deal with this problem and make their themes compatible. I really dont think that this is the case. I cant imagine that xiaomi releases a miui update that makes all themes unuseable but I rather think that there is something wrong with the xiaomi.eu rom itself and I really wonder why noone wants to or cant help with this issue.
 

Rhymes

Members
Aug 27, 2021
1
5
I have the same problem on my Mi 11 V12.5.11 My themes were working fine on V12.5.9 until I updated . Now every single theme on the app is showing not compatible. I think the problem is outdated theme app as current version of the theme manager app is 1.9.9.1 whiles the one on xiaomi.eu rom is 1.9.3.1 There is no way to update the theme manager app too as it does not allow us to install system apps from third party sources.
 
  • Like
Reactions: MarcBear

MarcBear

Members
Aug 20, 2021
15
5
I have the same problem on my Mi 11 V12.5.11 My themes were working fine on V12.5.9 until I updated . Now every single theme on the app is showing not compatible. I think the problem is outdated theme app as current version of the theme manager app is 1.9.9.1 whiles the one on xiaomi.eu rom is 1.9.3.1 There is no way to update the theme manager app too as it does not allow us to install system apps from third party sources.
It's a pity that xiaomi.eu doesnt say anything to that problem. Im really disappointed.
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,992
322
Was already answered if you bothered to search. We can't update the themes app without losing the global Fonts and Ringtones tabs.
 

MarcBear

Members
Aug 20, 2021
15
5
Was already answered if you bothered to search. We can't update the themes app without losing the global Fonts and Ringtones tabs.
Thats exactly what I read before but I dont see any explanation in your answer. I not only "bother to search" I also think about the answers you gave so far and realize that they make no real sense. In another threat you first answered that the themes are not marked as compatible by the designers. Then you said that you cant update the themes app. Two complete different answers and I guess the first one was wrong because it is obviously not a designer problem at all. So do you really wonder why people might ask again about this issue if you are not able to give clear statements? Still you have not said anything helpful. I still dont know if I have to deal with a non-working themes app in the future or if there is any chance that app can be updated in later rom-versions. If you ask me Id rather forget about those fonts and ringtones if that means I can get back fully compatible themes. and I dont think that Im the only one who thinks that way.
 
Last edited:
  • Like
Reactions: gang4

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,992
322
Thats exactly what I read before but I dont see any explanation in your answer. I not only "bother to search" I also think about the answers you gave so far and realize that they make no real sense. In another threat you first answered that the themes are not marked as compatible by the designers. Then you said that you cant update the themes app. Two complete different answers and I guess the first one was wrong because it is obviously not a designer problem at all.
Both are correct.
1) Themes that are not marked as compatible will show a warning, you may chose to ignore the warning and apply the theme anyway, but some parts of the UI will not be themed properly.
2) If the warning is bothering you, and if it was somehow removed in later versions of the app (haven't checked), we can't update the Themes app.
Point no. 2 was not an answer to "non-working themes app", but to the incompatibility warning dialog.

I just tested the first theme I found in the Themes app and it was applied perfectly without any warning - Lock screen, Home screen, Icons, Control center, Settings, Contacts/Dialer, Messaging, etc, all of them were themed properly. There is no issue with the Themes app.

So do you really wonder why people might ask again about this issue if you are not able to give clear statements? Still you have not said anything helpful.
I'm not your employee and I owe you no explanations, nor am I obliged to be "helpful" for everyone's inqueries.

I still dont know if I have to deal with a non-working themes app in the future or if there is any chance that app can be updated in later rom-versions.
If it's too much for you to bear, you're welcome to use any other ROM with the Global themes app in it, or whatever.

If you ask me Id rather forget about those fonts and ringtones if that means I can get back fully compatible themes. and I dont think that Im the only one who thinks that way.
It's our decision to make.
 

MarcBear

Members
Aug 20, 2021
15
5
Both are correct.
1) Themes that are not marked as compatible will show a warning, you may chose to ignore the warning and apply the theme anyway, but some parts of the UI will not be themed properly.
2) If the warning is bothering you, and if it was somehow removed in later versions of the app (haven't checked), we can't update the Themes app.
Point no. 2 was not an answer to "non-working themes app", but to the incompatibility warning dialog.

I just tested the first theme I found in the Themes app and it was applied perfectly without any warning - Lock screen, Home screen, Icons, Control center, Settings, Contacts/Dialer, Messaging, etc, all of them were themed properly. There is no issue with the Themes app.


I'm not your employee and I owe you no explanations, nor am I obliged to be "helpful" for everyone's inqueries.


If it's too much for you to bear, you're welcome to use any other ROM with the Global themes app in it, or whatever.


It's our decision to make.
Igor, Im really tired of your arrogant statements. Of course youre not my employee and f you dont WANT to help, just please dont answer. My initial question was, why all of my themes lost compatibility. Your answer was, that you cant update the themestore, so I had to understand this as the reason why my themes lost compatibility. NOW you say, that you tested the themes yourself and everything works fine. Congratulations. But this makes your first answer obsolete. Obviously it is no question about updating the themestore or not. But I realized that there are other users facing similar problems as I am. and that was the reason for me to start the thread again. If you mark the thread as invalid right away while saying that you cant update the theme store it doesnt help me in any way. if you dont want to understand that, then i really cant help you.
 
Last edited:

Igor Eisberg

Developer
Staff member
Oct 6, 2016
5,992
322
Igor, Im really tired of your arrogant statements. Of course youre not my employee and f you dont WANT to help, just please dont answer. My initial question was, why all of my themes lost compatibility. Your answer was, that you cant update the themestore, so I had to understand this as the reason why my themes lost compatibility. NOW you say, that you tested the themes yourself and everything works fine. Congratulations. But this makes your first answer obsolete. Obviously it is no question about updating the themestore or not. But I realized that there are other users facing similar problems as I am. and that was the reason for me to start the thread again. If you mark the thread as invalid right away while saying that you cant update the theme store it doesnt help me in any way. if you dont want to understand that, then i really cant help you.
My answer was directed at everyone posted before myself, including you, regarding the "incompatibility" issue, which I understand as referring to the dialog being shown when applying a theme, like Rhymes said: "Now every single theme on the app is showing not compatible".
If you're tired of my "arrogant statements", you may leave, no one is forcing your hand to stay and bear this "burden". As for your problem, nothing I can do for you. If you find the Stable V12.5.5 not stable enough, try the Weekly, where we patch things continuously. No one is going to re-release an old ROM for every single issue.
 
  • Like
Reactions: Poney70

MarcBear

Members
Aug 20, 2021
15
5
My answer was directed at everyone posted before myself, including you, regarding the "incompatibility" issue, which I understand as referring to the dialog being shown when applying a theme, like Rhymes said: "Now every single theme on the app is showing not compatible".
If you're tired of my "arrogant statements", you may leave, no one is forcing your hand to stay and bear this "burden". As for your problem, nothing I can do for you. If you find the Stable V12.5.5 not stable enough, try the Weekly, where we patch things continuously. No one is going to re-release an old ROM for every single issue.
ok, so your answer is that themes work perfectly fine for you on poco f3 with xiaomi.eu rom 12.5.5 and 12.5.6....so we are back at the beginning. it does not work for me and it does not work for many other poco f3 / redmi k40 users, although it worked perfectly with 12.5.4. as I said it was the reason for me to start this thread. just to hear if others have similar problems, maybe hints or even solutions. I certainly wont leave the forum just because you ignore some peoples problems with xiaomi.eu roms by marking threads as invalid.

There is another thread with the same problem: https://xiaomi.eu/community/threads/theme-app.62733/
You first answer that the themes are not compatible with the miui version, then you say, you cant update the themestore, but to me you say, that themes are working fine. you havent said that in any other thread so far. so there shouldnt be a compatibility issue at all. still there is one for a lot of k40/poco f3 users. why dont you want to accept this problem? if you cant do anything about it thats ok, although it is quite disappointing. still there would be no reason to mark our threads as invalid.
 
Last edited:

MarcBear

Members
Aug 20, 2021
15
5
Not sure if anyone else is interested but installing version 12.5.14 stable solved the issue for me, an invalid issue with an invalid solution :)
 
Last edited: