Trouble getting sound through optical on latest (4K) Mibox

Discussion in 'Xiaomi Mi Box / Mi TV' started by Zennon, Oct 20, 2014.

  1. Zennon

    ZennonMembers

    Oct 20, 2014
    2
    0
    11
    Hi all,

    Firstly, apologies if this is covered somewhere else, but couldn't find. I've got the latest mibox and am able to get video through the HDMI, but am not able to get any sound. I've played around with the audio settings in Chinese (spdif-raw, spdif-pcm, mono) and nothing seems to work.

    I'm using this kind of cable:
    http://www.crutchfield.com/p_703CPOM3M/AudioQuest-Cinnamon-OptiLink-3-meters-10-feet.html with the 2.5mm end going into the mibox and the other into the amp.

    Any help appreciated. I'm not sure if I need a different cable. Or could I just route the audio through the HDMI?

    Also if anyone knows how to work with the bluetooth on the device, please let me know - haven't seen any menu option on that.

    Zennon
     
  2. ouilly

    ouillyMembers

    Oct 11, 2014
    3
    0
    21
    Male
    Valdeavero
    hi, i think your cable is not the good one . I have tried with the same cable and doesn t work because the box doesn t have a optical output . It s digital output not optical . i use a cable with jack end and cinch in the other end and connect to coax input to the amp.

    I hope you understand my poor emglish
     
  3. Zennon

    ZennonMembers

    Oct 20, 2014
    2
    0
    11
    Thanks Ouilly, you're right. I hadn't realised that. So I got the right cable and can get sound, but it is only coming through in 2 channel, not 5.1 or 7.1. Do you know if the latest mibox supports that multichannel? My receiver only seems to see two regardless of PCM, Raw on the spdif output.
     
  4. madpb

    madpbMembers

    Oct 18, 2016
    1
    0
    11
    Male
    YES it has an optical digital ouput (can you see the red light?) and an analogue stereo output
    it says right in the manual S/PDIF or Headphones. So you can use a headphone jack but that means ONLY STEREO.
    You have the correct toslink cable . Your issue is most likely you receiver is unable to decode what is being sent to it.
     
  5. ysonmezer

    ysonmezerMembers

    Jan 7, 2017
    5
    0
    13
    Male
    Hello, have you tried to choose the option to switch on any TV in the TV box? If such an option is usually chosen, the problem can be solved. The audio codec component is then decoded on subsequent devices. (Such as Av Receivers). So The TV box is not interested in decryption. So the error will be removed.
     
  6. hypernative

    May 26, 2017
    10
    0
    3
    Male
    Hi
    Problem here also with SPDIF optical cable.

    Netflix can only get 2.0 sound to work. 5.1 sound is silent or maybe sound for 1-2 seconds.

    In Kodi DTS and Dolby digital is working fine!

    I have tried all the settings under sounds in the system menu.

    Any idea? Seems like a Netflix app has an issue?

    Sent from my FRD-L09 using Tapatalk
     

Share Our Site