TWRP don't boot, Phone don't boot neither


Arguuo

Members
Nov 3, 2017
33
20
Hello, I'm totally lost, I need some help
I received an unlocked Mi 8 (chinese version updated in a Global version), so the bootloader was already unlocked.
I started to install TWRP with adb, I booted in TWRP, everything worked well, I installed the last Xiaomi.eu ROM (weekly version MIUI10).
Then I Wiped Cache/Dalvik (no Format Data I remember, maybe it's the problem).
Then I rebooted the device, Mi Logo + Android load points for more than two hours..
I tried to reboot it, still blocked in Mi Logo, I tried to boot in TWRP, blocked in TWRP logo (no menu)..

Now I'm lost, what should I do ?
 

snake0101

Members
Jun 18, 2016
17
13
I had the same thing. I had to download the stock rom and flash it using the Mi Flash tool which brings it back to factory setting.
I seem to remember some warnings about bootloader locking when flashing (memory's foggy....) so try to get the same version you had before I guess?
It sounds like the device doesn't belong to your Mi account which could present a problem if it locks.
 
Nov 7, 2014
3
15
I have a similar issue to OP, I received a locked bootloader Mi 8, I unlocked it myself, and I can boot twrp via fastboot but not if I flash it. It flashes without issues but if I try to boot after I have flashed twrp I get bootloops. Mi logo for a few seconds then reboot and Mi logo again. I tried all versions I can find for this model and non seems to stick. I am currently on latest xiaomi.eu rom.
 
  • Like
Reactions: skan