Unable To Re-enable Wifi

Discussion in 'Redmi Pro' started by fuzzytv, Nov 24, 2016.

  1. fuzzytv

    fuzzytvMembers

    Nov 13, 2016
    18
    1
    15
    Male
    Hi... I'm running v6.9.8 of the Eu rom and recently encountered the issue of wifi being unable to turn wifi back on once it has been turned off unless the device is rebooted. Wifi can only be turned on again for 1 time only and if it is turned off and needs to be re-enabled, the device needs to be rebooted again.

    Any advice on the above 9n what could be the issue?

    Sent from my Redmi Pro using Tapatalk
     
  2. stefabona

    stefabonaMembers

    Nov 29, 2016
    4
    0
    13
    Male
    Hello everybody, same thing happens to me with redmi pro 32gb! With .24 firmware too..
     
  3. fuzzytv

    fuzzytvMembers

    Nov 13, 2016
    18
    1
    15
    Male
    I couldn't find a fix so I flashed back to stock Chinese rom and it's working fine now

    Sent from my Redmi Pro using Tapatalk
     
  4. fuzzytv

    fuzzytvMembers

    Nov 13, 2016
    18
    1
    15
    Male
    I think I might have found out what the cause of the issue is. Try this and see if it works for you. Goto permissions and remove the permissions for Google services for 'change wlan connectivity'.

    Sent from my Redmi Pro using Tapatalk
     
  5. stefabona

    stefabonaMembers

    Nov 29, 2016
    4
    0
    13
    Male
    Great! I will try and tell if it works!
     
  6. stefabona

    stefabonaMembers

    Nov 29, 2016
    4
    0
    13
    Male
    I'm not sure where to find the appropriate setting in my phone (italian ui). Please check the screenshots, am i in the right place?
    I cannot find "google services" in there..

    1.png2.png3.png
     
  7. Stewartbatallas

    Dec 7, 2016
    1
    0
    13
    Hello, I had te problem too and I tried a lot of solutions... but at the end, I have found it! You have to disabled the foreground search of wifi. See the screenshots for help but there are in Spanish . Go to wifi settings. Go under and enter into advanced settings. Now disabled the option 'search foreground permission' or 'search always on' or something like this.
     

    Attached Files:

  8. stefabona

    stefabonaMembers

    Nov 29, 2016
    4
    0
    13
    Male
    YES IT WORKS!! GREAT! THANK YOU!
     

Share Our Site