New Whatsapp, Telegram and other apps notifications plays sound event in "do not disburb"


the matrix

Members
Nov 24, 2010
56
20
Hello,
In MIUI 11 (and also in MIUI 10 but not in MIUI 9) some notifications (WhatsApp, Telegram, Wallapop,...) are playing sound even if "Do Not Disburb" is active.
Notification sounds are played if I allow phone calls while in "Do Not Disturb" but no if I disable phone calls while in this mode.
This is a bug due to notifications aren't the same of phone calls.

What's expected: No notification sounds while in "Do Not Disturb" even if phone calls are enabled in this mode.
 

moepkid

Members
Oct 3, 2019
9
15
Same problem here, right now on 9.10.10. For me its whatsapp. When I choose to "Allow calls from no one", the notifications stop making sound but thats not ideal
 

rvk220

Members
Sep 14, 2019
55
20
Yeah, the same problem! When DND was on, Viber notifications popped up with sound and woke me up, as if DND was off. It was this way also on xiaomi eu MIUI 10. That is why I never use DND. My phone is Redmi 5 Plus.
 
Last edited:

Floris92

Members
Nov 5, 2019
3
15
I think I found the solution! If you go to settings > Sound & vibration, you can set the calls/reminders/notifications volume. If you set this bar to zero, the sounds disappear, even if you enable incoming calls


26915
 

rvk220

Members
Sep 14, 2019
55
20
I think I found the solution! If you go to settings > Sound & vibration, you can set the calls/reminders/notifications volume. If you set this bar to zero, the sounds disappear, even if you enable incoming calls


View attachment 26915
Not a solution at all: if you turn off calls & notifications sound, you won't be able to hear calls from starred contacts.
 

rvk220

Members
Sep 14, 2019
55
20
Developers, please do not ignore this problem! It is crucially important for those who wish to use DND mode.
 

Richaaldo

Members
Nov 26, 2019
1
3
Another one here, tried separately to silent every detail of the notifications, the system automatically repulls the priority and original settings assigned, no matter if in dnd or out. Nothing works for keeping calls loud y silent all notifications. Please advise?
 

rvk220

Members
Sep 14, 2019
55
20
This old problem hasn't been fixed even till now!!! Notifications from Viber, Telegram etc. play sound in DND mode on 11.0.3.0, Mi Max 3. It's so annoying... Can't use DND because of this bug.
afc7cc42407f25b40042fbfa51da7686.jpg


Sent from my Redmi 5 Plus using Tapatalk
 

Ahmaddhiya

Members
Feb 4, 2021
1
3
The closest thing to a solution that i could think of is to set the ringtone of the notification to none.