New Wifi Slower On Marshmallow

Discussion in 'Bugs' started by ivo.hr, Jan 26, 2017.

  1. ivo.hr

    ivo.hrMembers

    Dec 11, 2016
    73
    9
    18
    Male
    In hope of helping someone else with this issue I’ll share what I found to be solution for problem with browser loading pages slower over Wi-FI since coming to marshmallow. For Croatian users who are on T-Mobile network and have ZTE 931VII router setting Google DNS in router seams to speed up Wi-Fi experience significantly. Maybe it works for other routers too. It doesn’t hurt to try.
     
  2. Pertti Kosunen

    Sep 2, 2014
    537
    140
    82
    Male
    #2Pertti Kosunen,Jan 26, 2017
    Last edited: Jan 26, 2017
    What rom do you have? 7.1.12 and 7.1.19 should have great wifi speed on Mi4, 6.12.15 - 7.1.5 were bad, 6.12.8 and few before at least were good.
     
  3. ivo.hr

    ivo.hrMembers

    Dec 11, 2016
    73
    9
    18
    Male
    7.1.19

    I have slow opening apps using Internet. Chrome, Play store, Weather app manual refresh, Youtube... I was on global stable a few weeks ago, all mentioned apps loaded faster but ROM itself seamed slower than this one. Also Chrome crashes in this one, some other browsers i tried too and mail app and calendar app have bugs. If those things were fixed it would be perfect for my needs.
     
  4. Pertti Kosunen

    Sep 2, 2014
    537
    140
    82
    Male
    Try wipe cache + dalvik from TWRP recovery.
     
  5. ivo.hr

    ivo.hrMembers

    Dec 11, 2016
    73
    9
    18
    Male
    Did that. No effect. It's the same with last few versions I tried. Thats why I went and tried global stable in the first place. Guess I'll have to wait and see if next few updates make a difference.
     
  6. deepknight

    deepknightMembers

    Sep 11, 2016
    20
    3
    15
    Male
    Try to disable miui optimization in developer settings. For me it gave me better data rates

    Gesendet von meinem Redmi 3S
     
  7. ivo.hr

    ivo.hrMembers

    Dec 11, 2016
    73
    9
    18
    Male
    Ok, so I found that slow wifi on my Mi4 was caused by my router. I got a hold of mikrotik router and set it up as AP and the difference is hudge!!! Everything opens instantly, apps using internet open fast and load content fast.

    Wifi problems started after upgrade to marshmallow so I gues my router works better on kitkat and has problems on marshmallow, would like to know why though.
     
  8. Pertti Kosunen

    Sep 2, 2014
    537
    140
    82
    Male
    Some routers work better when you disable TKIP encryption from wireless and use only AES.
     
  9. ivo.hr

    ivo.hrMembers

    Dec 11, 2016
    73
    9
    18
    Male
    Tried with my router and it makes no difference.

    I have ZTE 931VII - takes forewer to open anything using Internet over wifi yet the measured speed is 40Mbps. On mikrotik RB941-2ND AP connected to ZTE every app opens fast, pages load almost instantly, yet the speed measured is 20Mbps. My data plan is 50/10Mbps.

    Before upgrade to marshmallow from kitkat I had fast wifi over zte too.
     

Share Our Site