Resolved Wrong carrier name


Jisi

Members
Feb 10, 2012
14
1
13
#1
This happens on the MI1, but did also happen on the Huawei Honor I used before.

It does NOT happen on the MIUI Germany version.

My carrier is O2. All Roms I ever used show this (Usually they show "O2-de", as I am in Germany). The MIUI Version from http://miui-germany.de/wp/ also does this correctly.

The version from miuiandroid.com however shows "Tchibo". That is a brand of coffee shops here, and it seems they also resell some mobile phone contracts from O2, but my contract/SIMCard has nothing to do with them.

I already googled, that it seems i could hack some resource file or some such to "fix" this, but it would be nice if this mapping could be repaired for everyone. I'd be happy to provide the necessary information, if you tell me what you need.
 

ingbrzy

Xiaomi.eu Multilang leader
Staff member
Feb 11, 2012
8,321
17,502
322
#2
Will be fixed tomorrow... Thanks for the report... We need them to improve our work...
 

Jisi

Members
Feb 10, 2012
14
1
13
#4
We will see. I am still mildly optimistic and report back here if something changed... If not I will keep nagging :).Maybe your report just got lost, because there is no real bugtracker here. And also some of the volunteers needs to find the time to do it...
 

ingbrzy

Xiaomi.eu Multilang leader
Staff member
Feb 11, 2012
8,321
17,502
322
#5
dont worry.. we care about users.. :) its already fixed for 2.12.14.... :)
 
Dec 22, 2012
4
0
11
#12
Hi Guys,
This is supposed to be "o2-de" not "O2-DE" small letters not capital letters.

edit: 1st post, big thanks to everybody for making this rom so wonderful.
 
Dec 22, 2012
4
0
11
#17
Well if anybody want this is the real fix here

Replace the attached file in "system/framework" either in full rom zip or the language pack zip then flash it over.

Edit: MAKE A BACKUP OF YOUR ROM BEFORE FLASHING
 

Attachments

Mar 11, 2012
46
7
28
#23
Well then there is a bug. I first installed 2.12.21 and then on top of it the language pack - all from this MIUI page. In the last version i had installed, i didn't have the issue, don't know which version that was (one of the last three)
 
Mar 11, 2012
46
7
28
#24
Can we "open" this thread again so that it's clear that this issue isn't solved? How to do that? Or should i write a new thread?
 

ingbrzy

Xiaomi.eu Multilang leader
Staff member
Feb 11, 2012
8,321
17,502
322
#25
post screenshot with wrong carrier name...

so you have installed 2.12.21 + langpack 2.12.21 and using German language, right..?