Xiaomi Mi Box - Cannot Connect To Wifi


May 18, 2018
1
0
1
#1
I just got the Xiaomi Mi Box International (MDZ-16-AB) today, however I have had issues with connecting it to WiFi. No matter how many times I try to connect to my router, 2.4G or 5G, it says "Wi-Fi password not valid". I have checked very carefully that I have entered in the correct password. My router is a RS-500KI. Every other device is able to connect to it just fine.

Things I have tried:

  • Setting password to "WPA-PSK [TKIP] + WPA2-PSK [AES]"
  • Setting password to "WPA2-PSK [AES] "
  • Disabling 5GHz and attempting to connect to 2.4GHz
  • Disabling 2.4GHz and attempting to connect to 5GHz
  • Connecting via WPS -> "Connected successfully" message, but no connection. The connection is saved but trying to connect just gives the same "Wi-Fi password not valid".
  • Disabling WPS
  • Setting the 2.4GHz radio to b/g (instead of b/g/n)
  • Setting up a guest network and trying to connect to that
  • Using a simple password = "password"
  • Restarting the Mi Box
  • Restarting router
  • Android 6.0
  • 5GHZ has only 3 channel W52 /W53 /W56
None of the above have worked. The only thing that allows it to connect is if I disable the password, but of course I can't leave my network without a password.

Strangely enough I can also connect just fine to my mobile phone hotspot with WPA2 password. I have used this to get past the setup screen and test out the features of the box, but this isn't a long term solution.

Is anyone else having trouble connecting to the WiFi with their Mi Box or other Android Box? From googling I see that some people got the same invalid-password error with various android phones, which led me to take the troubleshooting steps above.
 
Aug 5, 2011
637
47
67
#2
My wifi works great and i have the box on 1st floors and my router on ground floor.
I would suggest you to try with a different router as soon as possible and if still doesn't work ask for a replacement
 
May 20, 2018
1
0
1
#3
Hi,

disable WLAN Protected Management Frames (PMF) on your router (wifi settings).

That solved my issues on AVM Fritzbox Routers.
Only the AVM tech team where able to figure out, that somehow the mi box is not able to handle PMF.

Best regards
Lenny