Xiaomi Redmi T9 fastboot loop


mkor1000

Members
Oct 17, 2021
1
3
Hello Xiaomers!

After I had tried to install custom TWRP image My Xiaomi Redmi T9 has been stuck in fastboot loop. These are complete steps taken me to this situation:
Before flashing custom TWRP recovery, I had unlocked booloader using Xiaomi Mi Unlock Tool, I had Google's latest usb driver installed on my Windows 10 computer ( https://dl-ssl.google.com/android/repository/latest_usb_driver_windows.zip). The android device was shown in Windows device manager and described as working correctly. adb and fastboot commands were able to connect to Xiaomi T9 device.

Below are the steps which have taken me to the current situation:

(1) I switched the device into USB debugging mode
(2) First i tried to download official TWRP application from Google Play, but every attempt to start flash recovery always crashed TWRP application
(3) Then I reverted to manual adb/fastboot based method described here: https://twrp.me/xiaomi/xiaomimi9t.html
(4) Downloaded twrp-3.5.2_9-0-davinci.img and saved it as twrp.img in android's studio platform tools folder
(5) Started with"adb reboot bootloader", which run fine.
(6) "fastboot flash recovery twrp.img" also run fine. Didn't save the output, but the message was clear the operation ended successfully.
(7) After running "fastboot reboot", the device has been stuck in fastboot.

I tried all possible combinations of power off/on and volume up/down buttons, but the device continues to boot into fastboot. The battery is not removable. adb and fastboot commands don't see the device any more. Android device was removed from Windows device manager. I was able to add Android ADB and Android Bootloader Interfaces by installing the same Google's latest usb driver which I had before the TWRP flash, but both interfaces show the same warning saying the device cannot be started (Code=10).

Any idea what could have happened? Does anyone hear about any issues with TWRP image mentioned? Why did "fastboot reboot" command removed the Android device from the Windows device manager? Any suggestion how to unbrick my phone? Many thanks!!
 

Poney70

Donator
Oct 3, 2019
5,471
337
Hello,

If you have a Redmi 9T, its codename is NOT "davinci" (= Mi 9T / Redmi K20 devices) but "lime" (= Redmi Note 9 4G / Redmi 9T / Redmi 9 Power devices). ;)

Flashing a TWRP not made for your device => 99% of chance bricking the device...

Try to hold " Volume - " and " Power " buttons simultaneously to reboot in fastboot mode. If your computer can't detect your device, then you can try to use the warranty of your phone by contacting the seller -OR- contact a "EDL Unbrick" paid service via Telegram (by example: @unbrickRU).