Xiaomi Router 3 Constantly Disconnecting


Mar 27, 2017
1
0
1
#1
Hello,

I bought this product, but it seems that I will loose my mind soon...
I replaced my old tp-link router because it got old, so I decided to go with AC router and xiaomi seemed like a good decision. But now I totally regret it - the wifi signal is getting lost all the time on all of the devices except iphones. I have LG TV, 2 macbooks and an onkyo receiver. Macbooks are loosing the connection all the time, and whats worse you cant reconnect unless you reboot the router. For example - me and my wife are sitting next to each other - and mine mac shows it is not connected to wifi anymore - and when reconnecting it gives error that something went wrong and cannot reconnect - even though my wife has wifi on, phones are also connected. So I need to restart router then. And this happens 5-8 times a day, the download is down to 3 mbps, when it was with 6 year old router 10 mpbs. Please explain me what is happening, how to fix this? Is this cause of both enabled 2.4 and 5g?

Thanks...
 
Apr 22, 2017
11
0
11
#2
Hi, I'm also having the problem in which my router after some time loses the connection and drops the wi-fi.
I bought it thinking that I would have a good router, but I'm just having a headache!
I can not navigate direct due to signal drops!
 
Apr 24, 2017
6
0
13
#5
No body cares about the issues with products after sale : prometheus.freize.net
I've found alternative FW, flashed and currently no issuess found...let we see next couple of days
 
Apr 22, 2017
11
0
11
#6
Prometheus also tried and could not put the FW in it.
Just have Russian tutorial, and do not explain step by step correctly!
Now it is to wait for a consultation and leave the equipment as a table top.
 

MarkHUK

Founder of Xiaomi.eu
Staff member
Nov 6, 2010
5,006
3,048
1,000,000
#7
Hi guys,

Did you also change the network locale to your region? It is important! If you didnt also set the Locale of the Network (Not just the UI language) then you will likely have the issue solved.

Please confirm. Obviously I can't speak for where you all buy from but any customer who purchase via our store can buy the official CE router V3 or Router Mini with no issues.

Mark
 
Apr 22, 2017
11
0
11
#8
Oi pessoal,

You also changed the location of the network to your region? Is important! If you didnt also set the network location (not just the UI language) then you probably have the problem solved.

Please confirm. Obviously I can not speak to where you all buy, but any customer who purchase through our store can buy the official CE router or V3 Mini Router smoothly.

Marcar
Well, I'll try to change the region!
I had not done it yet. It's like the Chinese.
 
Last edited by a moderator:
Apr 24, 2017
6
0
13
#10
There is a setting to change the network as well.... not just the language - Make sure its set to European:)
where is this setting? I'm already on prometheus, but it will be helpfull for others that have the same issue. you can just post a screenshot here
i wonder why this is not written in the guide
 

MarkHUK

Founder of Xiaomi.eu
Staff member
Nov 6, 2010
5,006
3,048
1,000,000
#11
where is this setting? I'm already on prometheus, but it will be helpfull for others that have the same issue. you can just post a screenshot here
i wonder why this is not written in the guide
Off hand can't remember the menu . but its around the Network / WAN settings / WiFi... I'd have to open one from Stock and boot it up...
 
Apr 22, 2017
11
0
11
#12
[QUOTE = "bobybc, post: 366854, member: 175040"] onde está essa configuração? Eu já estou em prometheus, mas será útil para outros que têm o mesmo problema. Você pode apenas postar uma captura de tela aqui
Eu me pergunto por que isso não está escrito no guia [/ QUOTE]

With prometheus did you heal this problem in the fall of the Wi-Fi signal?
 
Apr 24, 2017
6
0
13
#13
[QUOTE = "bobybc, post: 366854, member: 175040"] onde está essa configuração? Eu já estou em prometheus, mas será útil para outros que têm o mesmo problema. Você pode apenas postar uma captura de tela aqui
Eu me pergunto por que isso não está escrito no guia [/ QUOTE]

With prometheus did you heal this problem in the fall of the Wi-Fi signal?
no, there are no any issues with prometheus. it seems very stable. the cpu of the router is under 5% almost all the time, while with original FW it was above 60% mostly
 
Jun 19, 2016
16
3
15
#14
Be sure that you have no conflict with another router in your network.
I had these conflicts too and found out that I had 2 routers with DHCP activated.
Only one router must be he DHCP server.
I asked my provider to set my first modem/router into bridge mode. ( it splits the signal between internet and phone and is required)
Now my Router 3 is my DHCP and wifi router before my switch to my other PCs.
 
Jan 19, 2019
3
0
3
#17
I bought xiaomi router 3 recently it's also dropping signals connected with WiFi but my PC which is connected through Ethernet doing good. I change the channel to 1 because with automatic setting I was having the problem then for 2 days it was doing fine but today the issue arise again.....whether it a software problem or what I don't understand. If anyone can solve please help.