Fastboot not working - adb working

Jul 12, 2021
Device manager in Windows 10 sees the phone in adb - rebooting to fastboot no phone detected.

Tried to scan for hardware changes, disabled driver signature for win 10, changed usb ports, tried 2 other PC:s and one Mac, all the same! Of course I have tried numerous adb drivers, xiaomi usb drivers and so on.

Adb looks fine:
List of devices attached
12345ab device

After running "adb reboot fastboot" the phone reboots to fastboot as intended.

Being in fastboot mode when I try e.g. fastboot device it gets into the < waiting for any device > state and nothing happens. therefore the "windows_fastboot_update_rom.bat will not work either.


Sep 5, 2020
This sounds like the phone drivers on Windows to me - Windows can't connect to the device, so it's Windows where you solve it

I've had similar. Basically go into Device Manager - when your phone is connected you should see an ANDROID entry pop up

If it has a yellow exclamation you need to install your phone drivers. I can't be sure without knowing your phone but since my Mix 4 was new when I did it, I'm 99% sure I went with some generic Android drivers from Google