Impossible unlock bootloader again


Apr 30, 2016
Good morning everyone, I have a problem with my MI10. My MI account was created almost 10 years ago and I have always unlocked the bootloader of all the Xiaomi devices I have bought in this years without problems.

I currently own the MI10 and I have always had the bootloader unlocked to install the EU roms. A few days ago I saw that hyperOS was available for my phone so I flashed the stable stock rom V14.0.5.0.TJBMIXM to then be able to do the OTA update of HyperOS. Unfortunately, before the flash I didn't realize that the "clean all and lock" checkbox was selected. After the stable flash I updated via OTA to hyperOS and reconfigured the phone.

Unfortunately I noticed that when I use the Miflash unlock tool it is no longer possible to unlock the bootloader and I receive the message "couldn't unlock more devices this month". Normally I have never had problems with this account and now I don't know how to go back. The phone is in developer mode and USB debugging is active.

I have tried all the following attempts but I can't solve:

Tried putting the phone in fastboot mode and tried the miflash tool: "Erase is not allowed in Lock State"

When I go to MI Unlock Status and add the device, I get the message: "couldn't add. Please go to MI community to apply for auth..."

I opened the xiaomi community app (set to global) and clicked on unlock bootloader, then on "apply for unlocking" I receive the message "application quota limit reached..."

I've tried them all but I honestly don't understand why it's impossible to unlock the bootloader again to then be able to flash the twrp and restore the phone as it was previously configured.

Thank you if you can tell me a solution, because I need to have my phone unlocked
Hello, did you ever find a solution for this issue? I'm in the same situation with my Mi 10 Ultra, which is now a brick with broken modem after HyperOS update. Thanks.