Mi10 Pro not recognized at PC in Fastboot anymore


PascalDollansky

Members
Nov 30, 2016
66
20
Hi

I updated my Mi10 Pro to MIUI 13 xiaomi.eu ROM 22.1.5. and since that time the phone is not recognized in fastboot anymore when connected to my computer.
So I am not able to update to latest Weekly as this works only via Fastboot

First I thought something went wrong because the nice fastboot logo with the rabbit repairing the android robot was not there anymore, just the simple "fastboot" but I learned they changed the logo.

So fastboot on the device is shown, I can also still boot into TWRP but I can not see it on my computer when connected, the "fastboot devices" command does not show any device.

Any idea to support?

Thank you!
 

IvanGrozni

Members
May 25, 2021
11
15
Maybe you should restart your PC or reinstall ADB. Anyway - what camera software are you using on MIUI13 - G cam? Is it working properly? thx
 

katerpanne

Members
Apr 19, 2014
2,886
332
Hi

I updated my Mi10 Pro to MIUI 13 xiaomi.eu ROM 22.1.5. and since that time the phone is not recognized in fastboot anymore when connected to my computer.
So I am not able to update to latest Weekly as this works only via Fastboot

First I thought something went wrong because the nice fastboot logo with the rabbit repairing the android robot was not there anymore, just the simple "fastboot" but I learned they changed the logo.

So fastboot on the device is shown, I can also still boot into TWRP but I can not see it on my computer when connected, the "fastboot devices" command does not show any device.

Any idea to support?

Thank you!
in this topic are some hints…
 
  • Like
Reactions: biscoot

Hanabi1989

Members
Apr 12, 2019
2
13
Hi

I updated my Mi10 Pro to MIUI 13 xiaomi.eu ROM 22.1.5. and since that time the phone is not recognized in fastboot anymore when connected to my computer.
So I am not able to update to latest Weekly as this works only via Fastboot

First I thought something went wrong because the nice fastboot logo with the rabbit repairing the android robot was not there anymore, just the simple "fastboot" but I learned they changed the logo.

So fastboot on the device is shown, I can also still boot into TWRP but I can not see it on my computer when connected, the "fastboot devices" command does not show any device.

Any idea to support?

Thank you!
SAME HAPPENS TO ME!! TILL NOW IM STOCK 0N HENTAI OS!! SSSHMMM
ANYONE PLSS HELP US
 

Mark F

Members
Aug 15, 2020
642
102
Try different or the original cable. Try different set of ADB commands. Try different windows driver and try to use basic windows command prompt, not any updated replacement. And of course, make sure you have usb debug on.
 

katerpanne

Members
Apr 19, 2014
2,886
332
  • Like
Reactions: geoorg

Stefanlong

Members
Feb 28, 2022
52
20
Probieren Sie ein anderes oder das Originalkabel aus. Probieren Sie einen anderen Satz von ADB-Befehlen aus. Probieren Sie einen anderen Windows-Treiber aus und versuchen Sie, die grundlegende Windows-Eingabeaufforderung zu verwenden, keinen aktualisierten Ersatz. Und natürlich stellen Sie sicher, dass Sie USB-Debug aktiviert haben.
USB-Debug ON ? Why I thought FASTBOOT and ADB are different things - or should I wrong ...
 

PascalDollansky

Members
Nov 30, 2016
66
20
hi together… instead of writing help, it is not working etc

why dont you write what you did and what is the error message?

without any details dont spam the forum

here is a howto. if you have any further informations, solutions, I can update it.

please use the search function and read… thank you

your feedback is welcome :)

Maybe you should also read the problem is the phone is not recognized in fastboot so no possibility to install via fastboot

I did nothing upfront it was not recognized anymore at least nothing I can remember
 

levered93

Members
Jul 18, 2021
8
13
try the ADBDriverInstaller.exe
with this the device was recognized when running in normal mode and ADB drivers will be installed again if not working properly.
Once I have used this, it worked again
thats not works. i think my devices has not detect to fastboot anymore
 

katerpanne

Members
Apr 19, 2014
2,886
332
USB-Debug ON ? Why I thought FASTBOOT and ADB are different things - or should I wrong ...
you are right…

USB Debugging is responsible for ADB communication and not fastboot, both are different and if you want to mess with ADB then you need USB Debugging but for fastboot there's no need.

If you enter fastboot mode with "Power and Volume -" you dont need USB debugging.
But if you want to use "adb reboot bootloader" to enter fastboot mode, turn USB debugging on.
 

Stefanlong

Members
Feb 28, 2022
52
20
Du hast recht…

USB-Debugging ist für die ADB-Kommunikation und nicht für Fastboot verantwortlich. Beide sind unterschiedlich, und wenn Sie mit ADB herumspielen möchten, benötigen Sie USB-Debugging, aber für Fastboot ist dies nicht erforderlich.

Wenn Sie mit "Power and Volume -" in den Fastboot-Modus wechseln, benötigen Sie kein USB-Debugging.
Wenn Sie jedoch "adb reboot bootloader" verwenden möchten, um in den Fastboot-Modus zu wechseln, schalten Sie das USB-Debugging ein.
THX
 

sploits

Members
Jan 17, 2021
1
13
I was having this issue but then I found if I booted into fastboot from TWRP (so boot to TWRP first then from the reboot menu in there choose fastboot) it would open up its own version of fastboot and I can update without issue when a new update is released.

I hope this helps