In Progress No 3G on Vodafone NL

Discussion in 'Bugs' started by w3rd, May 3, 2012.

  1. w3rd

    w3rd Members

    Trophy Points:
    11
    Hi all,

    I'm having some issues getting my data working on my MI-ONE.
    I've got this issue for a while now but the problem occured ever since i've updated to ICS.
    I'm currently running 2.4.27.

    At first I thought my SIM card was getting old so I went to my carrier's shop and asked them to check it out. They've provided me with a new SIM card but still it wouldn't work. So they've checked a couple of things with a technician but there's no sign there's something wrong at their side.

    I've tried my SIM card in another phone and 3G works just fine there. I've also put several other SIM cards in my MI-ONE (even Vodafone NL Business, which uses a different APN - office.vodafone.nl instead of live.vodafone.com) and they all worked fine.

    Is there anyone who can help me out? I'm a 100% sure I'm using the right APN settings.
    Sometimes when I restart the phone or toggle the airplane mode I can see the 3g icon appear for a brief second but then it just disappears again.
  2. Google Adsense

  3. w3rd

    w3rd Members

    Trophy Points:
    11
    Updating to 2.5.4 did not fix the issue, still not working.
  4. Infinitely

    Infinitely Members

    Trophy Points:
    28
  5. shicomm

    shicomm Members

    Trophy Points:
    16
    Got exactly the same issue but on another dutch mobile network ( telfort / KPN )
    Also double checked the APN settings and they are ok.

    Running on 2.3.5 here...
  6. rarelyamson

    rarelyamson Members

    Trophy Points:
    18
    Have you deleted all other APN's?
  7. shicomm

    shicomm Members

    Trophy Points:
    16
    Did so ; no difference ...

    Will try the newest rom to see if that works...
    Unsure how to install that tough...

    UPDATE:

    A couple of reboots later after installing 2.3.5S ( from 2.3.5R) 3g works ! :D
  8. w3rd

    w3rd Members

    Trophy Points:
    11
    Running 2.5.18 now and I can reboot as much as I want but it won't get my 3G fixed :(
  9. shicomm

    shicomm Members

    Trophy Points:
    16
    That sucks...

    Problem is back with me also...
    Now running on 2.3.5v...
  10. shicomm

    shicomm Members

    Trophy Points:
    16
    UPDATE:

    I just updated my mi-one to ICS and the issue is SOLVED! :)
  11. w3rd

    w3rd Members

    Trophy Points:
    11
    I'm afraid it's still not working for me :(
    Running latest version 2.6.8
  12. Infinitely

    Infinitely Members

    Trophy Points:
    28
    Go to the updater app and install 2.6.13 and try again. ;)
  13. w3rd

    w3rd Members

    Trophy Points:
    11
    I'm afraid this also doesn't fix the issue.
  14. shicomm

    shicomm Members

    Trophy Points:
    16
    This might work :

    Open the dialer and give in this : *#*#4636#*#*

    Select phone information.
    In the list that comes up is the SET PREFERED NETWORK TYPE option.
    Choose that one and test another option ( there is quite a list ;) )

    I've used it to test on having 2g only , 3g pref. and 3g only
    ( a late miui GB only gave me 2g and 3g pref. with 3g not working ... )

    Vodafone might need the gsm (prl) option but i'm not sure...
    A friend of me is enigineer at vodafone , will ask him about this also...
  15. w3rd

    w3rd Members

    Trophy Points:
    11
    Thanks for your reply.
    As I recall, we're on WCDMA, so GSM/WCDMA Auto is the right option to use.
    This still allows us to switch to 2G networks so there's your 2G/3G Pref.

    Like you've asked I've PM'ed you so your friend can take a look at it.
    Still, I'm pretty sure it's a bug. Why should it work perfectly fine under GB and not under ICS?
  16. shicomm

    shicomm Members

    Trophy Points:
    16
    In NL we run gsm and wcdma if i'm right ;)
    EDGE is no longer in use ( my provider have used it in the past ;) ) ; LTE is there in a couple of cities but not nationwide...
    On KPN i'm on the gsm only setting but the PRL options might work .

    Having seen that in at least one version of GB it also worked i'm also quite sure that it's a bug...

    I noted somebody that also had the issue but on the htc desire ; he was on gsm/wcdma ( auto ) and solved the issue selecting the gsm only option.
  17. w3rd

    w3rd Members

    Trophy Points:
    11
    Running 2.7.6 now, still not working
  18. ice de ocampo

    ice de ocampo Members

    Trophy Points:
    1
    I have been doing some tests, and I think I figured out when the Network Type Selection works and when it fails.

    There must be some part of the code that checks if 3G is available before switching to 3G, or to 2G.

    You won't be able to switch if you THERE IS NO SERVICE (SIGNAL), this issue will be rather hard to recreate because most of our devs have very good service in their work places.

    I think what needs to be done is to disable the checking of the service and simply allow the switch, of course I am in no position to actually say if this is even possible since I haven't even checked the code out.
  19. lekzzz

    lekzzz Members

    Trophy Points:
    38
  20. w3rd

    w3rd Members

    Trophy Points:
    11
    The last part, about the pppd-ril.options, could be the issue but I was unable to locate this file on Miui.
  21. lekzzz

    lekzzz Members

    Trophy Points:
    38
    Yes, I couldn't find it too. Somebody at miui-au said it would work with their ROM, I will give it a try later this evening

    Sent from my HTC One X using Tapatalk 2

Share Our Site