New 2.5.25 (mi-one) system two update (possible fixed)

Discussion in 'Bugs' started by blackstones, May 29, 2012.

  1. blackstones

    Mar 29, 2012
    519
    49
    67
    Phone: xiaomi M1 Mi-one
    2.5.25 <->2.5.18 and 2.5.11
    Hey im having problems updating (downgrading) my phone.
    When i use system two and uses update.apk and choose 2.5.18 or 2.5.11 its start the update and then it updates system one instead. No matter what version 2.5.11 or 2.5.18 it updates system one instead of system two witch it should have done.

    I tried re-flashing the with miflash and the latest version from the xiaomi website 2.5.25 it flashed ok and i got xiaomi 2.5.25 on both system one and two but the same issue is still there.

    I updated the phone with miaandroid.com version and now how miuaandroid.com on system one and xiaomi on system two and i cant get miuiandroid on system two becuase it updates system 1 instead.

    Anybody else have issue updating/downgrading system two on the mi one after 2.5.11?

    So is there a bug in update.apk for miui since it updates system 1 instead of system two when you ask it to update system two.
     
  2. blackstones

    Mar 29, 2012
    519
    49
    67
    Just tried flashing multiple different versions and all have the same issues that i cant flash system two it flashes system one instead.
    Tried xiaomi wire srub miflash 2.3.5v, 2.5.4, 2.5.11 2.5.18 and 2.5.18 and same problem and even tried first release version of ICS and GB but no difference.

    Anybody know how to force flash system two?
     
  3. blackstones

    Mar 29, 2012
    519
    49
    67
    After a lot of tries i re-flashed again with mi-flash wire scrub 2.5.25 and updated with miui android 2.5.25 on both systems.
    And now both systems seems to be running 2.5.25 miui android, reason i think so i is that the logo shows
    https://www.dropbox.com/s/bimj50mfcn05pdw/Screenshot_2012-05-30-15-23-06.png
    Miui android and not the chinese symbols and LED settings are gone in settings.

    For now it works so hopefully it will manage to update later to 2.6.2 and versions to come in the future :)
    So people who do get problems updating/downgrading its probably best to not wire scrub and if you do you might be stuck on the newest wire scrubbed version on system two at least on version 2.5.25 and before this happend.
     

Share Our Site