AX3600 and mesh network problem with 9T Pro


Apr 10, 2019
I have created a mesh network with 2 AX3600. The problem I have is that the Mi 9T Pro when it changes the router by proximity, it takes all the Wi-Fi signal, but nevertheless it does not have an internet connection or is very slow. If I take and activate and deactivate the wifi switch of the mobile, perfect, the maximum speed. I have the latest Xiaomi EU 12.5.
However, with a Huawei M6 tablet, it makes the perfect router change, I always have the maximum speed.
I have tried with a Mi Mix 2S and with Miui it also failed. I tried to put Pixel Experience and it seems to be working fine.
In the 9T Pro I have tried to remove Miui and put the EvolutionX rom, and it keeps crashing.
I don't know what else to try. I have tried on the router to change channels, join the 2.5 / 5 networks, change the security ...
What can be?
@ojerez1975 @sparklingluz Try setting up WPA2 protection for 2.4 instead of stock setting "WPA/WPA2". Also keep in mind that if You will enable smart connect it will merge 2.4 and 5ghz settings (You will not be able to set WPA3).

Edit: after few test I now recommend disabling "smart connect". Not ot often but this occasionally causes switching between 2.4 and 5 gHz even if device is still in 5 gHz range.
Last edited:
I have very same problem.
I have a AX3600 router and a mi9t Pro.
If I stay close, the connection is perfect. But if I'm in the second room, and the internet connection is not used then after a few minutes my phone show full WiFi strength but message "this network don't have internet connection." If I turn off and on the WiFi on the phone works again a few minutes.
If I disable the smart connect function, it works well but I want to use the feature. The old "Vodafone" router worked without problem when the same feature was enabled. (It was only AC router without antennas )