Invalid Bluetooth Controller is not working Properly on Xbox Game Pass App


Inf1n1ty33

Members
Sep 14, 2020
1
13
Hi,

I don't know if I get help with this here, but I try :)

I have paired a Xbox One (also tried a new Xbox Series ) Wireless Controller to my Xiaomi Mi 9 Phone.

In the Xbox Gamepass Menu the Controller is working completly normal.

When I start a game the analog triggers and D-Pads are not working (which worked fine in Menu)

The Right Buttons are working normal. (A,B,X,Y)

I have also tried my Work-Phone (Sony Xperia XZ3).

On this Phone everything is working as expected.

I don't know if somebody can help me.

Thank you
 

Paulomodered

Members
Feb 4, 2021
2
3
same problem. In xiaomi mi 10 lite 5g...
In the xiaomi mi a2 with android one the controller works fine. the xbox controller and dualshock 4 works on xiaomi mi a2 and not work with xiaomi mi 10 lite 5g. MIUI 12
 
Mar 11, 2021
1
3
Hi guys, I've registered just for this, LOL.

I think this is an Android 11 bug, not specific to Xiaomi. My MI 10 Lite has suffered since the Android 11 update (aside: I'm not enjoying this phone anywhere as much as my last Redmi Note 2, especially since we now have to use Google apps for messaging, calendar, contacts etc - what did they do that for, I don't want a Pixel phone!!)

I got around it and got my old Moga Pro working in HID mode by doing the following. I am not using gesture navigation on the home screen, I use the old style navigation keys/bar (I have completely forgotten what that's called!!). I am also using the stock global 12.1.4 stable ROM that came via update to my stock phone (no root, stock recovery, no MIUI EU ROM on it yet - not sure if I'm keeping it!!).

1. Connect controller via bluetooth (not just pair, actually connect).
2. Head to Settings-> Additional settings->Accessibility and swipe to the Vision tab.
3. Tap Magnification and turn it on. You should get a little accessibility icon appear in the bottom right of the screen.
4. Tap the accessibility icon that just appeared to turn on screen magnification (you can stay on the same accessibility settings page while you do this).
5. Turn the magnification option off again under the vision tab (hopefully you're still on that page!!)
6. Press some buttons on your controller (not sure if this is essential).
7. Fire up a game and the controller should work again. I've tested my Moga Pro in Shadowgun and the Diii4a Doom 3 pc port and all is good again : ) I haven't rebooted yet so I've no idea if this is a one off thing.
8. Eat toast, frag stuff.

Credit goes to rustybathtub over on the OnePlus7 forum who used a slightly different method and I experimented based on that.

Good luck!!

EDIT: This workaround interferes with one handed mode when you activate it by sliding left or right from the home button. In order to get it working again you have to toggle one handed mode off and on again in settings. Unfortunately, this also stops the game controller workaround, um, working. In order to get THAT to work again, just turn one handed mode back off and run the game. Lol.
 
Last edited:

Twiztid

Members
Jul 19, 2021
3
3
i have the same problem on me MI 10. the magnification procedure did not solve my problem. ROM version I have MIUI 12.6 21.7.14