Bootloop Problem

Discussion in 'Xiaomi Mi 4' started by Shahar287, Jun 17, 2016.

  1. Shahar287

    Shahar287Members

    Dec 7, 2014
    30
    0
    26
    Male
    Rishon LeZion
    Hi guys. I'm having a problem that happens all the time. I am on 4.4.4 stable ROM, using my phone regularly for a while, when suddenly it crashes, goes to black screen and shows the mi logo. It tries to launch the system and then goes blackscreen again, launching mi logo, and blackscreeb again with endless loop. I figured out the suloution: im launching recovery mode, switching to the second system (dual system), and when it shows the mi logo it's seems ok, no loop. Im entering recovery mode again and switch back to system 1 and then it launches successfully. It happens once in every 3 weeks or a month, and I'm using my solution. I had a miui 7 developers, when they decided to merge the systems. And when this bootloop happened again, i was stuck because the only solution was to seotch between systems and i couldn't. So I've changed back to 4.4.4 with the dual system. But i really want to install miui 8 and i know i could get that bootloop again.
    Please anyone know what the hell is the problem and how can i fix this bootloop? Because i tried reset, format, flashing different roms and and version and this bootloop stays with me everytime.
    Thanks for your time and patience.
     
  2. shohidul islam jony

    Feb 9, 2016
    10
    0
    11
    Male
    First install china dev 5.12.17 then install any MM based rom

    Sent from my MI 4W using Tapatalk
     
  3. shohidul islam jony

    Feb 9, 2016
    10
    0
    11
    Male
    Try with a fastboot MM rom afterwards

    Sent from my MI 4W using Tapatalk
     
  4. Shahar287

    Shahar287Members

    Dec 7, 2014
    30
    0
    26
    Male
    Rishon LeZion
    What is mm? Marshmallow?
     
  5. Tetzi

    TetziMembers

    Jan 5, 2016
    159
    47
    40
    Male
  6. msdeepak

    msdeepakMembers

    Jun 30, 2016
    4
    0
    13
    Male
    My Mi4 suddenly one day phone got switched off.. tried to switch it on but got black screen. went to recovery there also same problem. if i touch the screen phone used to vibrate in recovery.
    I went and flashed global rom using fastboot method. its working.
    but again when i try to flash twrp recovery using fastboot method i am getting black screen.. can anyone of you please help me on this.
     
  7. Pertti Kosunen

    Sep 2, 2014
    568
    144
    82
    Male
    Which TWRP?

    How old is it, maybe battery starting to die?
     
  8. msdeepak

    msdeepakMembers

    Jun 30, 2016
    4
    0
    13
    Male
    trwp 3.0.0 as well as 3.0.2 , if battery starting to die it should not work for stock recovery and miui global rom as well, right. I am able to flash global rom using fastboot method and the rom is working fine, but not able to flash twrp
     
  9. Pertti Kosunen

    Sep 2, 2014
    568
    144
    82
    Male
  10. msdeepak

    msdeepakMembers

    Jun 30, 2016
    4
    0
    13
    Male
    yes. recovery gets flashed..black screen comes, when i touch the screen it vibrates as well.. but cant see anything
     
  11. Pertti Kosunen

    Sep 2, 2014
    568
    144
    82
    Male
    Might be some hardware issue. Battery can cause weird flashing problems, but then even global rom should not work anymore.

    Have you checked MD5 of twrp.img to verify it's not corrupted?
     
  12. msdeepak

    msdeepakMembers

    Jun 30, 2016
    4
    0
    13
    Male
    i think i found the problem... some how my bootloader is locked.. night will try to unlock it and will try to flash twrp again
     

Share Our Site