Cannot update to Stable 17 from Stable 15

Discussion in 'Xiaomi Redmi (Red Rice / HongMi)' started by Muppet Arms, Aug 17, 2014.

  1. Muppet Arms

    Mar 17, 2014
    27
    0
    11
    Male
    As stated above, I cannot get an update to work from what I have Stable 15 to Stable 17.
    Downloaded file is on my phone, but when I use the Updater App, the phone goes through as I would expect it to restarting.
    But after several tries the phone is staying at Stable 15.
    I have looked at some of the posts on this but none have helped.
    This is my First android phone and It has updated from 13 - 14 - 15 without any problems.
    I did find that ROOT permissions where turned off, so I fixed that.
    I have tried to use TWRP but the file that has downloaded is not an IMG file?
    The File miui_redmiw_mam_17.0.0_b4cbe8e.... is a zip file.
    I have got Super SU installed and running/working.

    What are the ways I can do an Update?
    1: the Updater App
    2: TWRP
    3: ???

    Info from the About Phone in Settings.

    Device Name: Hongmi phone
    Model Number: HM 1W
    Android version: 4.2.2 HM2013023
    MIUI Version: MIUI-15.0.0
    CPU: Quad-Core1.5GHz
    Ram: 1.00GB
    Internal Memory: 1.64 Available / 4.00GB total
    Baseband Version: MOLY.WR8.W1248.MD.W / GMP.V28.P38 / 2014/04/22 20.00
    Kernel Version: 3.4.5

    I did run a full backup but have never needed to restore from that, I dropped back to the default theme.
    There must be something I am doing wrong but being a newish user I don't know what that would be, all help welcome.
     
  2. edyros2003

    edyros2003Members

    Dec 20, 2013
    182
    32
    40
    Male
    Boot on Twrp Recovery, tap on install, choose downloaded zip file, swipe to confirm flash
     

    Attached Files:

  3. Muppet Arms

    Mar 17, 2014
    27
    0
    11
    Male
    #3Muppet Arms,Aug 18, 2014
    Last edited: Aug 18, 2014
    After I connected my phone to the computer I found that the miui_redmiw_mam_17.0.0_b4cbe8e....zip file was only 17k.
    So I downloaded the Full file from http://en.miui.com/download-82.html
    But that failed to install. I did have an older Rom zip file and I am using that, Hope this works.

    Ok the Old file worked. but I don't know what version it is?
    Is this Older then the 15 I had?
    MIUI-JHBCNAL5.0
    When I check for updates it tells me this is the most up to date version?
     
  4. zoul

    zoulMembers

    Aug 3, 2014
    19
    0
    11
    Male
    Try install using updater with the zip file u download from en.miui.com
     
  5. Muppet Arms

    Mar 17, 2014
    27
    0
    11
    Male
    #5Muppet Arms,Aug 22, 2014
    Last edited: Aug 22, 2014
    Do I have to rename the file? All I get is maybe 20% in and an error.
    Looks like I have Lost the Root access.
     
  6. zoul

    zoulMembers

    Aug 3, 2014
    19
    0
    11
    Male
    Try download the rom again from the official website. Install using updater through menu and select rom update from the downloaded folder. Switch of phone n reboot into recovery. Flash twrp. Once done. Take out battery n boot into recovery manually to enter twrp. Flash root-stable.zip .
     

Share Our Site