Can't activate SIM card


Paulinaiml

Members
Jul 28, 2020
7
3
Hello, I've got a xiaomi redmi note 8, MUI Global 11.0.9; and whenever I turn it up or reboot it, I get that Xiaomi SIM Activation Service can't activate the SIM card and I get the error "reach_downlink_sms_limitation".
Things I've tried so far:
1.- changing the SIM name with my phone number
2.- Allowing Mi account all permissions
3.- Allowing roaming
4.- Buying roaming messages
5.- I did manage to link my cell phone number to Mi account from the web (and I did manage to get the SMS on my phone)

How can I fix this? Furthermore, is it safe to attempt a bootload as it is?

Many thanks in advance
 
  • Like
Reactions: ankarage

KeBKR

Members
Apr 12, 2020
17
15
I found this on the internet, perhaps it'll work for you. If not I'll have to search for another solution.

Go to Settings SIM cards & mobile networks Data roaming and set Overseas data roaming to "Always". Then let it set up everything and turn it off again.

or

TURN-OFF Mi Messaging on your phone. This can be done by (while in Messaging) long press menu button to enter Message Settings then toggle the Mi Message to OFF.

or

Go to the apps manager and search for the app that has a Blue Mi Logo, it's called "Xiaomi Sim Activation Service".
Press on the app and go to the app permissions.
Here you have to enable SMS.
 

Paulinaiml

Members
Jul 28, 2020
7
3
Method 1: didn't work, tried many times
Method 2: I did download the app (it didn't come with my phone). I can't get to activate because of "couldn't verify phone number" error
Method 3: It already has full permissions. Tried toggling/rebboting and didn't work
 

KeBKR

Members
Apr 12, 2020
17
15
Are you allowed to send an international SMS? Is there any restriction from your carrier (perhaps your carrier it's blocking the activation numbers) ?
 

Paulinaiml

Members
Jul 28, 2020
7
3
I called the phone company and activated roaming service days ago. I did check and they told me the service is currently activated
 

KeBKR

Members
Apr 12, 2020
17
15
Try this please:

Go to Settings >> SIM cards & mobile networks >> Data roaming and set Overseas data roaming to "Always" (don't worry, this will only be for a few minutes).
Let the activation services run again (you may have to repeat the activation attempt a few times), and your device should be able to activate the SIM and verify the phone number. When it's completed, you can turn the Overseas data roaming back to "Never."
 

Paulinaiml

Members
Jul 28, 2020
7
3
Hi again
I toggled to never, rebooted, toggled back to "always", rebooted again, then reactivated about 10 times with no avail...
 

Paulinaiml

Members
Jul 28, 2020
7
3
I'm grateful anyway, you're the only person that has bothered to answer. The big question is: is a bootload safe and/or doable?
 

KeBKR

Members
Apr 12, 2020
17
15
Hello again,

If everything else works and you are not interested in the "advantages" of your Mi-Account (such as backup and sync) you can disable the notifications of the "Xiaomi Sim Activation Service"...
 

KeBKR

Members
Apr 12, 2020
17
15
It was just a way of getting rid of the notifications.
It is always possible to do a reboot...but I think you mean a (factory) reset?
I doubt if that solves your problem but you can always try.
Here's the link with instructions.


Good luck!
 

cerko

Members
Jul 6, 2020
3
15
Hello, I've got a xiaomi redmi note 8, MUI Global 11.0.9; and whenever I turn it up or reboot it, I get that Xiaomi SIM Activation Service can't activate the SIM card and I get the error "reach_downlink_sms_limitation".
Things I've tried so far:
1.- changing the SIM name with my phone number
2.- Allowing Mi account all permissions
3.- Allowing roaming
4.- Buying roaming messages
5.- I did manage to link my cell phone number to Mi account from the web (and I did manage to get the SMS on my phone)

How can I fix this? Furthermore, is it safe to attempt a bootload as it is?

Many thanks in advance
Hello. I hope you fixed it by now,but im gonna try to help anyway.
I have the same problem with all my devices after unlocking and installing custom rom.
Hell, i was forcing my wifes begonia to do ota from global to global/eu and it bugged out. So...
I do it like this.

1: turn off find my device and log out your mi account on your device

2: turn off data and wifi (i usually pop the sim out)

3: settings/connection and sharing/reset wifi and network.

4:settings/additional settings/language&input/change the language to any other one.

5:Turn off the device and pop the sim back in (if you took it out).

6: Boot up. Revert the language back to the one you use. Enable data and log back in to your mi account. Turn on sync and find my device.

Sometimes it works right away after reseting the network options and changing the language. But most of the times i have to do it in order i typed above.

There is a possibility that you will have multiple devices on your mi account,so you can to go to mi cloud and remove the duplicates under the find my device tab.

Same thing with google acc,go to your security/devices and delete the old or duplicate ones.
There is no real need to do that but hey, while you are at it why not.

Reboot,wipe,reset,data format,any of the options never worked for me it only made "duplicate" devices in my mi account.

Good luck and take care mate.
 

ankarage

Members
Sep 21, 2020
4
13
Hello, I've got a xiaomi redmi note 8, MUI Global 11.0.9; and whenever I turn it up or reboot it, I get that Xiaomi SIM Activation Service can't activate the SIM card and I get the error "reach_downlink_sms_limitation".
Things I've tried so far:
1.- changing the SIM name with my phone number
2.- Allowing Mi account all permissions
3.- Allowing roaming
4.- Buying roaming messages
5.- I did manage to link my cell phone number to Mi account from the web (and I did manage to get the SMS on my phone)

How can I fix this? Furthermore, is it safe to attempt a bootload as it is?

Many thanks in advance
I had the same problem .I had tried a lot of solutions .Nothing.
Your suggestion for the name of sin with the tel number was the solution .
Thank you.