Disable proximity sensor


nailui

Members
Sep 10, 2021
1
3
Hi,

I own a Redmi Note 9 (MIUI 12.5.1.0 (RJOEUXM)) and I have a problem with the proximity sensor.

I can't tell if it's the same problem as everybody or it's due to some 50 cm fall on a wooden surface (phone inside original silicon cover).

My question is this: how can I disable this sensor, if I don't have the option in the 'incoming calls' menu?
Is there another way?

Thanks for sharing info!

PS
Behavior of problem:
1. When phone ringing at incoming calls I don't get the full screen anymore. I have only the short version of incoming calls on the top of the screen.
2. When answering the phone, my screen goes dark and can't see anything, can't bring the light back on, double tap or main right button won't wake the screen up.
3. In the CIT tests, I get 0.0 reading on the sensor. Only in one position, with the front camera in full sun, I get 5.0
4. When the phone is locked, double tap on screen does only a quick flash to show the screen and then goes back dark.
Pocket mode is disabled.
 

jwchips

Members
Sep 22, 2011
107
30
1. Is this a proximity sensor thing? I thought it was just floating notifications, try disabling that for the phone app (you can also tap the name/number of the 'short version' to get the full screen layout)

2. Settings - Apps - System App Settings - Call Settings - Incoming Call Settings - Proximity Sensor

To answer your question of disabling the sensor entirely, there's probably a property you can edit? Have a trawl through with the SetEdit app on the play store. Other methods (like unbinding the driver) don't survive reboots and I think (Ed)Xposed is overkill