Extremely Hard Brick...


Sep 26, 2014
Hello guys, it's nice to be part of this great community. My English are not that good so please be patient with my explanations.

Well , I'm quite desperate here. A friend of mine gave me this phone (Redmi) bricked.

First of all the mobile can't boot, it says tool dl image fail. Even worst I can't even select the options in the boot menu, the tool dl image fail appears again. That means the memory is almost empty...

According to my experience the solution was only 1, Flash tools.

But again , I tried the Firmware/Update option of these ROMs: Xiaomi Hongmi WCDMA (HM2013023_images_JHBCNAL5.0_4.2)/ TD (Hongmi_images_HBJ2.02_4.2) - unbrick 5.0 and....NOTHING!

If I choose the download option but the bar reaches only 1% and theen I have this : s_ft_download_fail (4008). I tried the HM2013023_images_JHBCNAH4.0_4.2 but with the same results.

An extra detail is that IF I choose the format option, althought it doesn't complete...my mobile doesn't open after that. In order to be working again, I just have to choose the download option (till the 1%) and the it boots with the above problems.

To be more clear I installed the necessary drivers, I removed them, I installed them again...NOTHING. I changed the USB port, the same results..

An interesting quotation is that if I try to connect the device with a different USB cable that the original, the pc doesn't even recognize it (mobile). Also, I've noticed that the flash tools cannot install these (from the scatter) : Android, Cache, UserData & Fat.

As for the CMW Recovery ... no luck at all. They are all in image format which means, I can not install it.

Any help will be appreciated....althought I'm pretty sure the phone is 99% dead..


Mar 31, 2011
Friend, when you flashed one of those firmwares, the preloader became corrupted or it is the wrong/mismatched preloader. I discovered that the "4" firmware doesn't apply to the Redmi 1. The problem now is to get the PC to show preloader driver not any other MTK driver during the first part of the connection in the SP Flash tool (bottom right). There is a useful article at this link. Open device manager, connect without battery, double click on the device when it appears briefly, then browse to the driver in the folder manually, and DO NOT allow Windows updater to install a driver (it will install the wrong driver). I disconnected my pc from the internet to subvert that windows update process. Keep on trying. You may have to choose a driver already installed and select the preloader. You might also uninstall previous drivers using USBdeview. Good luck.