Find Device Storage Corrupted, Your Device is Unsafe Now


Areusure

Members
Dec 21, 2017
8
13
Find Device Storage Corrupted, Your Device is Unsafe Now

Started seeing this error every time my note 3 is turned on - anyone one else haveing the same or know the fix?

Currently running 10.3.1.0CHCNXM Stable with unlocked bootloader, found these sites which say I need to flash persist partition


When I try to flash it via FastbootI get the following error

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot devices
bf00c219 fastboot

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash persist persist.img
target reported max download size of 536870912 bytes
sending 'persist' (5184 KB)...
OKAY [ 0.156s]
writing 'persist'...
FAILED (remote: Partition is write protected)
finished. total time: 0.156s

Can anyone tell me how to fix this?, any help much appreciated

Thanks
 

werty

Members
Jun 13, 2018
365
52
Thanks for the response Shady88 I've read that thread and checked my sensors using Aida64 and all my sensors appear to be working fine
You are running xiaomi.eu rom or the official china rom? If you are using the first one flash the official rom with MiFlash and check if the problem persists. If everything is good flash recovery and eu rom again.
 

Shady88

Members
Aug 24, 2019
23
5
I've had that problem and the only thing that fixed it was flashing in order china developer, china stable and global stable from fastboot (flashing global stable only didn't fix it for me). I'm not sure but i've read that that problem is related to the persist image, it might be corrupted even if drivers are okay, it containts other drivers other than accelerometer etc etc. You can try backup persist from twrp and try flashing the one in the link, if it doesn't work you can flash back the backup. Other tentative is flashing from fastboot as i told you those roms in those order
Just make a complete backup just to be sure
 

Areusure

Members
Dec 21, 2017
8
13
You are running xiaomi.eu rom or the official china rom? If you are using the first one flash the official rom with MiFlash and check if the problem persists. If everything is good flash recovery and eu rom again.
Thanks Werty, will look at it over the weekend
 

Areusure

Members
Dec 21, 2017
8
13
I've had that problem and the only thing that fixed it was flashing in order china developer, china stable and global stable from fastboot (flashing global stable only didn't fix it for me). I'm not sure but i've read that that problem is related to the persist image, it might be corrupted even if drivers are okay, it containts other drivers other than accelerometer etc etc. You can try backup persist from twrp and try flashing the one in the link, if it doesn't work you can flash back the backup. Other tentative is flashing from fastboot as i told you those roms in those order
Just make a complete backup just to be sure
Hi Shady88 I flashed persist with your file above and still the same I'm afraid - looks like its going to be a complete wipe and try different roms to get rid of this annoying problem.
 

Shady88

Members
Aug 24, 2019
23
5
Yeah, i hated it too! It took me days to fix it!
Try with the chinese and global fastboot rom flash as i told you! Wipe all except persist from twrp before doing it!
 

Shady88

Members
Aug 24, 2019
23
5
I'm having the same issue now because i well thought of formatting vendor from twrp to clean flash everything from scratch.
Not fixed until now. Have you tried to get in edl mode? I seem to remember that when i have had that problem i tried to flash rom in edl mode and also to edit the fastboot rom flashing file to only flash persist, i didn't work but once i flashed older china rom it all came back working. Also i don't have any network at all
 

Shady88

Members
Aug 24, 2019
23
5
I fixed it. Apparently, since flashing persist from twrp the actual system can't get it to work at all. I tried to flash from fastboot the oldest china rom i have and started it (9.2.1.0) and everything was back working, networks working and that hateful message didn't appeared. You can try to dirty flash the latest rom over the actual one or even the same version and see if it fixes it. If it doesn't, you can try a clean install with older china roms like i said in other topics, from older to latest, and see it it works
 

Areusure

Members
Dec 21, 2017
8
13
Hi Shady88

I have at last managed to fix this - I noticed a problem with apps using the compass since I flashed persist partition with your file above. So in an effort to fix this before a complete wipe and flash with various roms - I re-flashed the persist partion with the backup I made of it before flashing it with the file you posted and now the compass is working fine and I no longer see the 'Find Device Storage Corrupted, Your Device is Unsafe Now' every time thephone is turned on.

I dont know if doing this would help any others with the issue but it worked for me.

Thanks again
 

Azlan MN

Members
Sep 19, 2015
11
15
I remember reading that persist stores calibrated settings that are specific to your phone. If you replace it with stuff from another phone else things are gonna work less effectively. For example, stuff like your compass, gps, network signal strength, etc.