Google Account Sync Not Working


maomao

Members
Dec 9, 2016
9
15
I just received my Mi5s (64/3GB) yesterday, and did unlock it, put the latest stable China ROM to it and with TWRP I loaded the EU ROM over it.

EU ROM: xiaomi.eu_multi_MI5S_V8.0.10.0.MAGCNDH_v8-6.0
Stable CN ROM: capricorn_V8.0.18.0.MAGCNDI_20161122.0000.00_6.0_cn_67352be4ef

However i was having trouble with TWRP, when booting after putting this on, with vol- and power, I came back to Fastboot each time. But when I use the updater app in MIUI, and go to reboot to recovery mode i still end up with TWRP. I hope this means this is still correct then? Any way my phone settings state I'm running MIUI by xiaomi.eu 8.0 stable.

I do have still one issue, a difficult one with my Google account. In the play store it works fine, I am logged on via the setup wizzard of Xiaomi, with both my Google and Mi account. It worked fine then.

But when I go to settings > Other Accounts > Google I see Sync issues. Sync is currently experiencing problems. It will be back shortly. Is the message.

In apps like Gmail it show waiting for sync with a spinning circle.

I have given app permissions it did request, also I have swiped my entire phone with TWRP to give it another try but end up with the same situation.

When using the browser i can just log in to Gmail and calendar without problems.

Anyone has an idea for how to make the sync work (I think that's the problem?)?
 

sseleraci

Members
Jun 20, 2016
61
18
I had the same google sync issues before, I even tried to clean flash official global beta rom, after reboot, sync didn't work too.
So I flash back eu rom and login my mi account (normally I don't use mi acc), tried dial *#*#checkin#*#* to force google update then google syncing as it should be.
I almost gave up miui and I don't know what made google sync works again.
Kenzo
 

Gabri98

Members
Dec 2, 2016
26
15
Search this on Google
[Tools, Tips & Tutorials] [MIUI Device Team] Google Apps - GApps for MARSHMALLOW & NOUGAT

You can try to flash on TWRP with the following method
Wipe cache
Wipe dalvik cache
Then flash the gapps package for marshmallow and reboot the phone.
 

maomao

Members
Dec 9, 2016
9
15
Well i've figured it out myself, turned out that in G Suites Android Sync was disabled.