Message box starts flashing when trying to connect Android Auto


Apr 24, 2022
This is what happens when I connect my 11T to my Peugeot to use android auto. The message box starts flashing uncontrollably, I cant tap on any option. Completely unusable. I am using the original cable that has no problem charging or connecting to a computer. If I use older type C cable that came with my Note 8 Pro - the phone starts charging and there is no option to use android auto - (just like connecting it to charging block). Android Auto works with a Samsung A72. How do I fix this?

The video file was too large for the site so I had to upload it on youtube:
Last edited by a moderator:


May 25, 2022
I have a Xiaomi Mi 11 with 13.0.8 installed. I also have a Peugeot and I have the exact same issue. I have tried to connect the phone with multiple cables but it doesn't work. Even tried disabling USB debugging and dual apps. Not really sure what the solution is here since Android Auto is launching with the same cable on my Oneplus 8T.


May 29, 2022
Same here with my Mi 11 and a Toyota.
Not flashing that fast, but still the same problem of reconnect-loop.
Tried several cabels, including the original shipped Xiaomi cable.
This is frustrating af :(

PS: browsing through several posts about AA problems it seems like a well known problem with MIUI, which is (maybe?!) fixed in the roms available here for download, but is still (since years!) not fixed my Xiaomi.
So there is one "solution" going round in the community: either wait even longer for a fix by Xiaomi, or flash a rom yourself (ofc only when you know what you do and are aware of a risk bricking your device!)
Last edited: