[Mi 11 Ultra] Problems with BT interruption (cellular network temporarily unavailable) AAWireless


n_a_p

Members
Jan 10, 2022
14
15
Hi everyone,
I have a problem which I noticed when using AAWireless (Android Auto Wireless Adapter). Whenever the cellular network is gone for a short time (dead zone, underground car park), the Wi-Fi connection from the Mi 11 Ultra to AAWireless is disconnected. As soon as the cellular network is back, the Wi-Fi connection is disconnected again. But in both cases it builds up again immediately (about 5 seconds).

So an example which I can understand when driving through a deep forest without a mobile network connection. First disconnect if there is no more network and if the network comes back 500m further, then comes the second disconnect. Between the two interruptions, the Wi-Fi connection to AAWireless was re-established and will continue to work after the second interruption until the next dead zone.

Or when I drive into an underground car park. Everything works for the first few meters in the underground car park, but as soon as the cellular network is no longer there, the Wi-Fi connection to AAWireless is disconnected (but also re-established immediately). Incidentally, when I drive out of the underground car park, the same thing happens, AAWireless is connected and there is no cellular network. When I drive out of the underground car park and it finds the cellular network, the Wi-Fi disconnects for a moment.

Ok, it will reconnect after a few seconds, I could certainly live with it. But it is very annoying when the music stops or you navigate with Google Maps.

Everything works with a cable connection and the problems only occurred with an update of the xiaomi.eu stable.

Device: Mi 11 Ultra 8/256 CN version with xiaomi.eu stable
Provider: O2 Germany

Previous history:
No problems with xiaomi.eu Stable 12.5.12, AAWireless worked without Wi-Fi interruptions.
From xiaomi.eu stable 12.5.17 the problem occurred, also with stable 12.5.20.
Meanwhile I installed MIUI 13 (13.0.5.0 Stable) and the problem persists.

Update 2022.03.07: Still the same error after switching to the weekly (full wipe) on now Weekly 2022.03.03.

AAWireless has the 1.8.0 update.
In my opinion, it cannot be due to the head unit of the vehicle (Kia Proceed 10.25"), as it would only be affected after the AAWireless adapter.

In the settings of the Mi 11 Ultra I have already activated "Mobile data always active" in the developer options and deactivated everything in the Wi-Fi assistant. Only the option "if the current Wi-Fi has no internet, mobile data should be used" was active. But this option no longer exists in MIUI 13.

This option is important because when connected to AAWireless the Internet only works via mobile data. As I was able to test it with MIUI 13, it still works even though this setting is no longer available.

Does anyone have a tip here as to whether there is still a setting option here? Or is there a problem here in the ROM for the Mi 11 Ultra? Or something completely different?

Many thanks for your help!
 
Last edited:

Valeri Kolev

Members
Nov 16, 2016
26
15
I have same issue with Mi 11 venus and AAWireless adapter.

I have tested on 09/21 Skoda with factory enabled wireless Android auto and it has same behavior. This confirms that issue has nothing with AAWireless adapter, but with phone.
Same bug was there in A11, after that it was OK with first few releases of A12 and then reappeared in MIU 12.6 and MIUI 13.

I have downgraded to A12 MIUI 12.6 21.10.22 xiaomi.eu rom where wireless android auto is running just perfect - with factory enabled HU and with AAWireless adapter.

Can't see many complains about the bug as it can be easily missed if you drive in good coverage area. I personaly haven't noticed the bug for few months until last summer when I drove abroad for vacation. It was noticable when switching between diferent opeartors in roaming.

It really seems that something causes that short interruption of WIFI connection when mobile data is lost/reconnected. Hope someone experieanced in sowtware can compare both rom versions and find a solution.
 

n_a_p

Members
Jan 10, 2022
14
15
Yesterday I switched from the stable 13.0.5 to the weekly 22.2.9, this with a full format so that it is really cleanly installed. This was a tip from thunder43, where he said that it should work again with 22.2.9.
After I set everything up again, including a new connection to AAWireless, I drove to a route where I know that there are always crashes if there is no network for a short time. Unfortunately, the WiFi crashes are still there as they were under the stable. Also in the underground car park, of course.
 
  • Like
Reactions: ZedeN

virtualmick

Members
Feb 24, 2022
2
15
Did anyone find a resolution or a rom that fixes this issue. Have the same symptoms with a Redmi Note 10 Pro. At the moment I'm on stock Xiaomi miui 13, but will happily migrate to xiaomi.eu if it's been fixed in a recent version!

Thanks all
 
  • Like
Reactions: n_a_p

XiaFan

Members
Feb 24, 2022
1
5
Same here, for me the disconnect issue is quite annoying as my car shows the message "Mi 11 - Android Auto Connection Lost" each and every time.... In rural areas and on the motorway this sometimes happens every 10 seconds. With this issue Android Auto wireless is not useable for me. Does anyone have an idea how to fix this?
 
  • Like
Reactions: n_a_p

n_a_p

Members
Jan 10, 2022
14
15
Hi Igor,

thanks for your reply in the weekly thread.

Yes, you're right, I could have posted logs a long time ago. To be honest, I didn't know which one.

First:
I now have the one you posted in the other thread regarding 5GHz channels.

Code:
adb logcat -s wificond,wpa_supplicant,WifiCountryCode,WifiNative,WifiNl80211Manager,WifiService > wifi_log.txt

Attached is my log. I just tried to replicate it. With a notebook and a Mi 11 Ultra (restarted) connected to it and the AAwireless adapter (it only needs power via USB), I walked through the underground car park to the surface, where cell phone reception was available again.

From "03-07 12:29:14.706" trying to connect with AAWireless
From "03-07 12:29:14.948" connected with AAWireless

This time I was also able to follow what is happening with the WiFi on the Mi 11 Ultra. It seems, and so does the log, that no WiFi interruption has taken place.

You will probably see the same thing in the log. So, contrary to my assumption, it doesn't seem to be a WiFi crash.

But I could see that Android Auto terminated the connection and reestablished it. Screen moved briefly from right to left in the WiFi screen in this Moment.

And what I noticed in the log at the times of these aborts are the following lines:

03-07 12:31:52.570 3211 3211 I wpa_supplicant: nl80211: Set SAR mode: enable=11 spec=2 sar_version=2
03-07 12:31:52.570 3211 3211 E wpa_supplicant: nl80211: Set SAR mode failed: ret=-22 (Invalid argument)

I don't have this in normal WiFi operation.


Second:
Now I've tried something else. I connected to AAWireless and recorded the screen and created the log at the same time. Everything is commented in the video and the log contains exactly this period of time.

+ wifi_log Screencapture
To compare the times with the log, you can use in the Video "second 36" as a reference. Here the time changes to 13:13.

It might also be related to Bluetooth. At least that's what I found in the log.
03-07 13:13:03.792 15766 15766 I wpa_supplicant: set_bt_active: 0
03-07 13:13:08.184 15766 15766 I wpa_supplicant: set_bt_active: 1
Bluetooth is also required for AAWireless. But only a guess, since I discovered it in the log.

I don't know if that will help you now.
Are there any other logs I can create that might help you.

Thanks in any case for your help.
 

Attachments

  • wifi_log.txt
    253.8 KB · Views: 42
  • wifi_log Screencapture.txt
    8.2 KB · Views: 44
Last edited:

n_a_p

Members
Jan 10, 2022
14
15
Addendum: I tested it again now. When I turn off airplane mode and the cellular network comes back up, the Bluetooth connection to AAWireless disconnects, apparently losing the Android Auto connection through the adapter. Although he is still connected via WiFi.

However, the Bluetooth connection to the AAWireless adapter is reestablished within 5 seconds and Android Auto is also reconnected. As seen in the video.

At the same time, my Galaxy Watch Active 2 was still connected via Bluetooth. This Bluetooth connection remained, no disconnect!

But even if I switched off the watch completely and only AAWireless is connected, its Bluetooth connection is disconnected when deactivating airplane mode (cellular network comes back).

So it could be a Bluetooth problem, because here why the AAWireless adapter is then disconnected for a short time.
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,465
322
No idea why you made a log with a command that was specifically intended for country code debugging...
In any case, that log is incomplete.

To be honest, I didn't know which one.
A normal unfiltered log, as described in the sticky thread in Bugs subforum...
 
  • Like
Reactions: n_a_p

n_a_p

Members
Jan 10, 2022
14
15
Ok, I actually overlooked that with the unfiltered log.

I have now created a unfiltered log while reproducing the problem. The process is the same as in the video.

Download: Google Drive

It's crazy how much log is generated in a minute.
But to make it easier for you, here's what I did during the log:

1. Airplane mode on (first line)
2. Bluetooth on
3. WiFi on
4. AAWireless connected via Bluetooth and then via WiFi.
5. Airplane mode off

03-07 16:23:44.522 3795 3795 I Tile.MiuiAirplaneModeTile: send click msg

So that you have a Timestamp to orientate yourself when turning off airplane mode.

6. AAWireless-awtDVYOG (BT) (and by extension Android Auto) was disconnected when Cellular Network came back.
7. AAWireless-awtDVYOG (BT) reconnected
8. Android Auto was available again.

My Galaxy Watch Active 2 has not disconnected at point 6 or throughout the log.

I hope this is now so suitable for you.

Thank you
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,465
322
Too much going on in that log, warnings and errors are all over the place, especially spam from a Samsung app.
The best hint I found was these entries that are logged when the mobile data connection is restored:
Code:
W CAR.GAL.GAL.LITE: IO exception, dataReceived=true
W CAR.GAL.GAL.LITE: java.net.SocketException: Software caused connection abort
W CAR.GAL.GAL.LITE: 	at java.net.SocketInputStream.socketRead0(Native Method)
W CAR.GAL.GAL.LITE: 	at java.net.SocketInputStream.socketRead(SocketInputStream.java:119)
W CAR.GAL.GAL.LITE: 	at java.net.SocketInputStream.read(SocketInputStream.java:176)
W CAR.GAL.GAL.LITE: 	at java.net.SocketInputStream.read(SocketInputStream.java:144)
W CAR.GAL.GAL.LITE: 	at ilm.run(SourceFile:9)
I GH.CarConnSession: Tearing down
E CAR.SETUP.LITE: ProjectionErrorCode = PROTOCOL_IO_ERROR(3), ProjectionErrorDetail = READER_CLOSE(52), io error
I CAR.SETUP.SERVICE.LITE: tearDown
I CAR.STARTUP.LITE: Tearing down car connection
I GH.CAR  : Stopping session: -6393401825328550332
I GH.CarConnSessMgr: Teardown called for session -6393401825328550332, current session is -6393401825328550332
I GH.CarConnSessMgr: Tearing down active session
I GH.CarConnSessMgr: Revoking active session
I GH.CarService: RemoteException notifying listener hny@4a8049d onDisconnected.
W CAR.SERVICE: Critical error 3 detail: 52 msg: io error
Log entries with "CAR.*" tags are logged by Android Auto app.
In any case, I don't see any literal crash or anything to do with the ROM itself.
 

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,465
322

Valeri Kolev

Members
Nov 16, 2016
26
15
Hi Igor,
Let me not agree the issue is related to AA.
Same AA version used to have stable connection with A12 MIUI 12.6 21.10.22 xiaomi.eu rom. May be one or two following releases could work too- not sure which is the last one.
Issue appeared later, both in MIUI 12.6 and MIUI 13.
Obviously reason should be some changes in the rom. Not saying you did something, probably it comes from china weekly. May be the working release should be compared with a later one and to see which change is causing the problem.

Edit: not sure it is related, but this may help - I have noticed that issue appeared when fastboot bunny was replaced with "fastboot"....
 
Last edited:
  • Like
Reactions: Neutron82

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,465
322
Hi Igor,
Let me not agree the issue is related to AA.
Same AA version used to have stable connection with A12 MIUI 12.6 21.10.22 xiaomi.eu rom. May be one or two following releases could work too- not sure which is the last one.
Issue appeared later, both in MIUI 12.6 and MIUI 13.
Obviously reason should be some changes in the rom. Not saying you did something, probably it comes from china weekly. May be the working release should be compared with a later one and to see which change is causing the problem.
Doesn't change the fact that we have no knowledge of how Android Auto works, as we're not Google engineers.
All I'm saying is that the errors are reported by Android Auto app, why they happen is not specified.

Edit: not sure it is related, but this may help - I have noticed that issue appeared when fastboot bunny was replaced with "fastboot"....
Irrelevant...
 
  • Like
Reactions: JiaiJ

Valeri Kolev

Members
Nov 16, 2016
26
15
Doesn't change the fact that we have no knowledge of how Android Auto works, as we're not Google engineers.
All I'm saying is that the errors are reported by Android Auto app, why they happen is not specified.
As an active driver and AA user I have searched and read a lot about the issue and have to say in 99% of mentioned cases it is MIUI.(not xiaomi.eu rom only, but stock as well). So, who knows what MIUI developers messed up, but we hoped you might be able to do something as you know the rom quite well.

Irrelevant...
Of course irrelevant. Just marks the moment when problem did start, in case someone is going to track changes.
 
  • Like
Reactions: Neutron82

n_a_p

Members
Jan 10, 2022
14
15
Thanks for your answer!
Too much going on in that log, warnings and errors are all over the place, especially spam from a Samsung app.
Yes, I actually only had a full wipe 3 weeks ago and it's nice to see that the Samsung apps from my smartwatch are doing such nonsense. Although I can probably be glad that everything works.
The best hint I found was these entries that are logged when the mobile data connection is restored:
Log entries with "CAR.*" tags are logged by Android Auto app.
In any case, I don't see any literal crash or anything to do with the ROM itself.
Ok, this actually looks like Android Auto itself.
But I don't understand why Bluetooth then goes out for a short time with the AAWireless adapter if there is no existing cellular network or when it is back.

Yesterday I deleted the Android Auto app updates and manually installed an APK from August 31, 2021.
At that time I didn't have any problems, but the behavior with the BT abort also occurs with this APK.

For me, the error actually only occurred with an update from the xiaomi.eu stable 12.5.12 to the stable 12.5.17. With the 12.5.12 everything went without problems.

Can't it still be that something has been adjusted here by Xiaomi?
Because you hear nothing from other manufacturers in connection with this problem.
 
  • Like
Reactions: Neutron82

Xeranos

Members
Mar 15, 2022
2
5
Hello there,

This issue is happening to me too. But I am not using an adapter.
My model is Redmi Note 10 Pro and I'm using AA with a wireless connection to my car (BMW) over WiFi / Bluetooth.

Every time the cellular network is not available or even switches from 4G to 3G or 2G my AA crashes and restarts itself. When driving in rural areas this is very annoying. If an 4G cellular connection is stable there is no problem at all. I could not figure out what's causing this.

This issue appeared after the update from MIUI 12.5 Global to MIUI 13 Global (13.0.3.0 SKFEUXM), so I'm not using any special ROM but the official ones.
Before that update everything worked like a charm but after the update it started crashing. No update on any other hardware (car) was made.

AA version is 7.3.620524-release.
I've already tried clearing the cache of AA.

Maybe, if you want to, I can also take an ADB log without a Samsung Smart Watch spamming the log files...

Thank you :)
 
  • Like
Reactions: Neutron82

Dehumanizer

Members
Mar 31, 2022
6
5
I have the same problem and it's clearly a MIUI issue, as there are no reports of such crashes with other (stock or non-stock) ROMs whatsoever. I'm just wondering if there are not enough people using wireless android auto with MIUI that MIUI developers are not doing anything with this for such a long time since it stopped working.
Can anyone confirm that it still doesn't work with the latest beta?
 
  • Like
Reactions: Neutron82

JayDRM

Members
Mar 22, 2022
5
5
Hi everyone,
I have a problem which I noticed when using AAWireless (Android Auto Wireless Adapter). Whenever the cellular network is gone for a short time (dead zone, underground car park), the Wi-Fi connection from the Mi 11 Ultra to AAWireless is disconnected. As soon as the cellular network is back, the Wi-Fi connection is disconnected again. But in both cases it builds up again immediately (about 5 seconds).

So an example which I can understand when driving through a deep forest without a mobile network connection. First disconnect if there is no more network and if the network comes back 500m further, then comes the second disconnect. Between the two interruptions, the Wi-Fi connection to AAWireless was re-established and will continue to work after the second interruption until the next dead zone.

Or when I drive into an underground car park. Everything works for the first few meters in the underground car park, but as soon as the cellular network is no longer there, the Wi-Fi connection to AAWireless is disconnected (but also re-established immediately). Incidentally, when I drive out of the underground car park, the same thing happens, AAWireless is connected and there is no cellular network. When I drive out of the underground car park and it finds the cellular network, the Wi-Fi disconnects for a moment.

Ok, it will reconnect after a few seconds, I could certainly live with it. But it is very annoying when the music stops or you navigate with Google Maps.

Everything works with a cable connection and the problems only occurred with an update of the xiaomi.eu stable.

Device: Mi 11 Ultra 8/256 CN version with xiaomi.eu stable
Provider: O2 Germany

Previous history:
No problems with xiaomi.eu Stable 12.5.12, AAWireless worked without Wi-Fi interruptions.
From xiaomi.eu stable 12.5.17 the problem occurred, also with stable 12.5.20.
Meanwhile I installed MIUI 13 (13.0.5.0 Stable) and the problem persists.

Update 2022.03.07: Still the same error after switching to the weekly (full wipe) on now Weekly 2022.03.03.

AAWireless has the 1.8.0 update.
In my opinion, it cannot be due to the head unit of the vehicle (Kia Proceed 10.25"), as it would only be affected after the AAWireless adapter.

In the settings of the Mi 11 Ultra I have already activated "Mobile data always active" in the developer options and deactivated everything in the Wi-Fi assistant. Only the option "if the current Wi-Fi has no internet, mobile data should be used" was active. But this option no longer exists in MIUI 13.

This option is important because when connected to AAWireless the Internet only works via mobile data. As I was able to test it with MIUI 13, it still works even though this setting is no longer available.

Does anyone have a tip here as to whether there is still a setting option here? Or is there a problem here in the ROM for the Mi 11 Ultra? Or something completely different?

Many thanks for your help!
 

JayDRM

Members
Mar 22, 2022
5
5

Attachments

  • IMG_20220331_165523.jpg
    IMG_20220331_165523.jpg
    78.2 KB · Views: 112