New [Mi Mix 3] Call issue


TheosKratos

Members
Dec 12, 2015
31
20
I am having an issue with calls. When i try to call someone, the phone gives the network not available error. I receive calls normally, and i can also send and receive sms no problem. Mobile internet is also no problem. My mobile network signal is always at 50% at the worst. Tried to reboot, wipe cache/dalvik, reinstall the latest weekly rom, and got in contact with support of my network operator, who detected no problems in my area. I also tried to use my network card on other phones and worked flawlessly, which leads me to think that is something wrong on my phone. Haven't tried to do a factory reset since that is my last resort... is there anything else i could try to do to fix this? Thank you
 
  • Like
Reactions: Tesla_42

Karpfenhai

Members
Jul 17, 2016
884
102
I am having an issue with calls. When i try to call someone, the phone gives the network not available error. I receive calls normally, and i can also send and receive sms no problem. Mobile internet is also no problem. My mobile network signal is always at 50% at the worst. Tried to reboot, wipe cache/dalvik, reinstall the latest weekly rom, and got in contact with support of my network operator, who detected no problems in my area. I also tried to use my network card on other phones and worked flawlessly, which leads me to think that is something wrong on my phone. Haven't tried to do a factory reset since that is my last resort... is there anything else i could try to do to fix this? Thank you
Might be wrong but are you using 3 rd party dialer and forgot to get permission to make phone calls?

Regards.

Sent from my MI 8 Explorer Edition using Tapatalk
 

Tesla_42

Members
Apr 26, 2019
29
15
I am having an issue with calls. When i try to call someone, the phone gives the network not available error. I receive calls normally, and i can also send and receive sms no problem. Mobile internet is also no problem. My mobile network signal is always at 50% at the worst. Tried to reboot, wipe cache/dalvik, reinstall the latest weekly rom, and got in contact with support of my network operator, who detected no problems in my area. I also tried to use my network card on other phones and worked flawlessly, which leads me to think that is something wrong on my phone. Haven't tried to do a factory reset since that is my last resort... is there anything else i could try to do to fix this? Thank you
Got the same problem since today with my Mi9, with most of the steps you did as well. No idea why this happens...
 

TheosKratos

Members
Dec 12, 2015
31
20
After a complete factory reset, i finally got it to work. The culprit: an update to the ACC magisk module that somehow broke outgoing calls... how in the hell is this possible? I don't even... *facepalm*

Got the same problem since today with my Mi9, with most of the steps you did as well. No idea why this happens...

Well if you use ACC magisk module, you might want to check that. If not... well i don't know. Factory reset might work.
 
  • Like
Reactions: Tesla_42

Tesla_42

Members
Apr 26, 2019
29
15
After a complete factory reset, i finally got it to work. The culprit: an update to the ACC magisk module that somehow broke outgoing calls... how in the hell is this possible? I don't even... *facepalm*



Well if you use ACC magisk module, you might want to check that. If not... well i don't know. Factory reset might work.
Incredible! Seems to be the reason, I'm also using it and had trouble with the last update (disappeared/uninstalled without reason, had to reinstall it several times).
Thanks a lot for this hint, I'll try to remove it and see if I can get it working without a factory reset.

Removed the module, now doing a dirty reflash of ROM and magisk. Let's see... Don't understand as well how this can be possible, it shouldn't affect calling and stuff. Too bad...

Edit: calling works again. No factory reset. Phew.
 
Last edited: