MI Router 10000 bug


Feb 15, 2024
The gods must know why I bought my MI 10000 router as there is absolutely no help to be found anywhere on the net.
My problems are many, but I will start with the most urgent. Last night my PLEX started constantly asking me to check the connection to my server. This happens from time to time and normaly a restart of the router is the solution. But not this time. I have done a lot of speed measurements. The speed is usually around 860 mbps and a ping of 6 ms, but now the speed is 87 mbps and ping is 12 ms.
I belive to have tried everything. I have found that if I set the 2.4 ghz network to a base width of 40 Mhz, the measurement shows 145 mbps, so I assume that my router suddenly thinks it must exclusively use the 2.4 Ghz network and that Wi-Fi multiband for some reason does not work as it should. If I turn Wi-Fi multiband off, I can access 2.4 Ghz and 5 Ghz-Gaming-Mode, but I cannot access the regular 5 Ghz channel. Here I get a message that it cannot be accessed.
And before anyone thinks I'm an idiot and just needs to reset my router, it's been tried. It's been tried so many times that I almost have calluses on my fingers and so many times that I'm done buying routers with only Chinese firmware.
I really hope there are others out there who can help me. And if it is, I have a thousand other questions about this router :)
Last edited:
I have same router, worst idea ever. It doesn't support USB modems and dual WAN with USB devices, so no fallback. I had that in 10YO+ ASUS. I have had several questions but never got through with remarks or feedback. Language support shouldn't be a big deal. Xiaomi doesn't give a flying duck.
Today it just dropped WAN for no reason and wouldn't reconnect without reboot.
I'm not recommending it to anyone.