New Mi11 very poor WLAN and Mobile Connection Receive Power .


WinstonWolf

Members
Jul 7, 2021
1
3
My Problems are :

- very poor WLAN Receive Power ( maybe the Antenna ) , i change my AVM Fritzbox against an new one , but still the same Problems . Mesh Thettering / Switching dont work perfectely . With my Company Phone , an Iphone 11 the Mesh Roaming works like charm and it receives in my kitchen 560 MB/s with the 5GHz WLAN.

My Mi11 drops down in Kitchen, wich is 3 meters away from the Fritzbox to 10MB/s or it loose the Connection completely . The Mesh roaming dont work too.
Till the Mi11 change to my Repeater the Bandwith goes down to 5 MB/s the maybe it switches to the Repeater who can deliver again 500 MB/s .



- Poor Mobile Network Power . I loose the Connection on Calls on Places where i can take Calls with my old Huawei Phone.



Am I the only one with these problems or do others feel the same way?



Thanks

Michael
 

VortexHD

Members
Aug 28, 2020
7
13
I have had my MI 11 for a while now and haven't noticed any of these issues.
WiFi and Mobile strength and speed have been great. There is a noticeable improvement over my MI 9.

Not really sure what else you can try other than a factory reset. It could be faulty so could be worth returning for a replacement.
 

osnix

Members
May 14, 2021
354
87
My Problems are :

- very poor WLAN Receive Power ( maybe the Antenna ) , i change my AVM Fritzbox against an new one , but still the same Problems . Mesh Thettering / Switching dont work perfectely . With my Company Phone , an Iphone 11 the Mesh Roaming works like charm and it receives in my kitchen 560 MB/s with the 5GHz WLAN.

My Mi11 drops down in Kitchen, wich is 3 meters away from the Fritzbox to 10MB/s or it loose the Connection completely . The Mesh roaming dont work too.
Till the Mi11 change to my Repeater the Bandwith goes down to 5 MB/s the maybe it switches to the Repeater who can deliver again 500 MB/s .



- Poor Mobile Network Power . I loose the Connection on Calls on Places where i can take Calls with my old Huawei Phone.



Am I the only one with these problems or do others feel the same way?



Thanks

Michael

I cannot confirm that. My Mi 11 is fine with AVM.

What you see is most likely a configuration issue in your network.

Traditionally the Fritzbox will configure 5 & 2.4 GHz with one SSID.
Now depending on your smartphone settings, eg: quick switch AP or connect to best Signal/AP the smartphone will use 2.4 GHz not 5 GHz, this seem to be what you are seeing. The matter will be worse if you use mesh or repeater set that way too, since then it jumps over mesh, repeater and bounces between 5 & 2.4 GHz. Another thing is old repeater who don't understand a wifi 6 request. While the phone is fine with wifi 5, the repeater may drop it first to something known to work, eg 2.4 Ghz and wifi 4 or alike.

I have 1GB cable connection which is over-provisioned by 150MBits, in the same room with the router the phone is maxing out the line, up and download. In the kitchen with closed doors, I still get 90%+, outside in the garden, like 15 to 20 meters away from the router, door closed, I'm still getting 65% to 80%. Also, no problems if I use mesh.

Also another thing with AVM, be sure you use a none DFS 5 GHz channel, better use a fixed one manually set.