New Mi2 data network not working after update 3.8.9!

Discussion in 'Bugs' started by Nico W., Aug 16, 2013.

  1. Nico W.

    Nico W.Members

    Dec 16, 2012
    34
    6
    18
    Male
    Hi,
    I would like to thank the developers on MIUI android for all their hard work, so thank you.
    However as developers you must realize that when you engage yourself in developing for the mass, that you also have a certain responsability to bare. That being said, concerning this last update you should be ashamed of yourselves. It completely wrecked my phone.
    My last update was in march this year and it worked great until last month. So quite a long time it took before becoming buggy. Respect for this stable release (aries) from march that i also downloaded on this website for my Mi2. Now i updated to version 3.8.9 through the updater app, after performing a full backup. I rebooted into the new version (on the other partition), as advised through a text balloon on my screen. Once inside the new version, everything starts to FC on me. Couldn't even make a phone call, whilst it was urgent! Network data (3G etc.) does not work, GPS does not work. Something really needed to be done.
    So i started by trying to reboot through recovery into the other system, this jammed up completely each time. After reading on your forum where someone told he wiped user data and it worked for him, i did that. Didn't work! Then i wiped all data! Finally the system with the newer version worked without FC'ing everything, but still no network data, no GPS. I restored my backup on this new system partition and not everything came back as it should. Widgets no longer on the screen, shazam dissapeared. I even tried to reinstall shazam out of my backup file on solo basis and still it didn't work!
    My phone is completely fucked up after this update and i am really really dissatisfied!
    Please help me out and do not be vague, i have supported enough PITA of this update allready today.
    Thanks in advance for any help of a proffessional.

    Sincerely
     
  2. Jos Groot Lipman

    Aug 12, 2013
    2
    0
    11
    Male
    After wiping the userdata I did not have network data as well. It took me a while but finally I remembered that my SIM-card (dutch Rabomobiel) does not set the correct APN information automatically. After setting that again I got my 3G connection back.
     

Share Our Site