New Mi6 Weird cellular data problem


Mar 9, 2019
I have a weird problem with my Mi6. When using cellular data certain apps can't connect to the internet. For example Facebook and Messenger work perfectly, as does Gmail or any other Google service. Other apps like Spotify, Uber and basically any other tell me that I have no internet connection. Snapchat is a curious case because I can send snaps and see thumbnails on "discover" page, but I cannot load snaps (although I get notifications when I receive one, which makes it even weirder). Chrome is affected too, but on a strange principle, because some pages load perfeclty (fe. Wikipedia, Instagram, Google, some of my news providers, which are rather unpopular sites) and others get ERR_ADDRESS_UNREACHABLE error (the same goes for the built in Xiaomi "Internet" app, error 105, no DNS address found). When i switch to Wi-Fi everything works perfecly fine. I've had this issue since first half of December, but I cannot recall if it was caused by an update or anything. I could've lived with that until now, because my new job requires me to be online all the time, and sadly the app I need is affected by the problem. I couldn't find any solution for the issue here, nor anywhere else on the web.
I know that my phone is the problem, not the provider, because I tried my SIM card in another phone (Mi Note 3 to be specific) and it worked perfectly there. Also I tried putting another SIM in my Mi6 and the problem was still there.

Additional info:
- I am running 9.3.7 right now.
- Sim card is in slot 2, because slot 1 stopped working for some reason a long time ago (Idk if this is helpful)
- I have never installed any apps from outside of Google Play
- The issue doesn't occur when using Wi-Fi connection.
I tried to take some steps, which include:
- Resetting the cellular settings / Deleting all APNs and creating new one
- Checking the data limits and app permissions
- Doing a factory reset (without wiping internal storage)

I've been running ROM (weekly) since 07.2017 and always had great experience, I hope you can help me solve this problem.
Last edited: