Resolved Mi9 9.12.27 beta - Set Preffered Network Type


mxxxt

Members
Apr 9, 2019
119
40
Since the last update, when I set the preffered network type to LTE/WCDMA, after a reboot the network type is set back to LTE/UMTS auto (PRL).

Can anyone else confirm it on Mi9?

It was same on stock ROM, but the settings were saved on xiaomi.eu before this update.

Thanks.
 

Attachments

  • IMG_20191231_113055.jpg
    IMG_20191231_113055.jpg
    262.4 KB · Views: 443
  • IMG_20191231_113125.jpg
    IMG_20191231_113125.jpg
    266.9 KB · Views: 538

Igor Eisberg

Developer
Staff member
Oct 6, 2016
7,317
322
Since the last update, when I set the preffered network type to LTE/WCDMA, after a reboot the network type is set back to LTE/UMTS auto (PRL).

Can anyone else confirm it on Mi9?

It was same on stock ROM, but the settings were saved on xiaomi.eu before this update.

Thanks.
You're not supposed to set network type using that panel, it's not intended for end users.
You already have a "Preferred network type" setting for each SIM in "SIM cards & mobile networks" settings.
Don't report bugs when you're using engineering/testing hidden panels instead of ones intended for end user...
 

mxxxt

Members
Apr 9, 2019
119
40
You're not supposed to set network type using that panel, it's not intended for end users.
You already have a "Preferred network type" setting for each SIM in "SIM cards & mobile networks" settings.
Don't report bugs when you're using engineering/testing hidden panels instead of ones intended for end user...

It's true, but also the settings under SIM cards and mobile networks are not saved, after a reboot the they are back to default...
Doesn't make sense to do the settings after every reboot.

Any chance to fix that or it's up to Xiaomi?

Poslano z mojega MI 9 z uporabo Tapatalk
 

ygorigor

Members
May 30, 2011
13
25
@Igor Eisberg On Redmi Note 5 Pro I have the same issue. If I change the preferred network type in settings - sim cards, after reboot it revert back to GSM/WCDMA/LTE. I notice this issue on 9.12.26 and 20.1.2
 

trahzebuck

Members
Nov 26, 2018
309
167
This is a known issue - at least for me. It was gone with Android 10. I could select the correct network type in the sim card settings menu.
With one of the last weeklies the issue came back and I have to use an USSD Code. But I have to do it again after every reboot.
 

mxxxt

Members
Apr 9, 2019
119
40
Working again on 20.1.9 rom. Thanks!

Poslano z mojega MI 9 z uporabo Tapatalk