New Xiaomi User Questions


Nov 13, 2023

i recently bought the Xiaomi Redmi Note 12 4G from,
it seems nothing i want to have works on this phone, esp adblockers.

1. When i login to TikTok, i cant it says "Use diffrent method" ... i think it is blocked somehow
2. when i try to acces or similar websites like
i get the message , "Adress not found" everything else workes fine.

i tried to switch dns to dns.adguard but that did nothing. i pretty new to this phone, it seems like they blocked alot of content i have no other explanation.
on other devices these things work fine in my network.

Can someone help me please ? thank you.
i just discoverd the issue here:
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.

this guy has a similar problem to mine. i tried now withmobile network and everything works just fine, when i switch back to my wlan it doenst.
how can that be ? any suggestions ? thanks
I think, i solved the problem by adding the MAC adress of my phone to my registered devices on my router... during that process i realized the name of the device couldn't be detected from my phone (on my router). so i switchted DHCP back to "auto" on my redmi phone, and it worked.
My router sees my phone now and has its own ip adress. So im not sure what happend but it seemd a problem with DNS/DHCP.
Lastly i have to mention my phone was set on "auto" in the beginning when it didn't work, so im not sure what solved the issue.
Just writeing this here for future people who might have the same issue. best of luck.