Poco F2 Pro bricked after update miui 13 weekly

Poco loco

Mar 2, 2022
hello i tried to update my poco f2 pro and had to wait for unlock bootloader.
after i could unlock it, i wanted to install latest weekly.
Then the script didnt finished and could not write anything in the middle.
Well after that the fastboot logo stucked (still the old one because phone was on miui 12 with android 11 i guess)
i tried to re run the script, but phone was no longer recognized.
After reboot with power button, the phone won`t turn on, only red circle led for charging lights.
I can`t boot in any mode either it does not got recognized by computer. So the EDL Mode won`t work right?
Tried my computer and laptop as well. The cable is okay, i flashed another poco f2 pro perviously and it worked.
After some research and reading, sadly this means my motherboard is just bricked right?
But how could this happen? I did everything the same as always, i already flashed 4 poco f2 pro the same way.
Just bad luck i guess? Some people said that when you update your phone, the phone itself gets really hot and that may lead to the lost connection from cpu -> motherboard.
Could this happen or how does they brick that way?