Problem with ARCore


Aug 24, 2021
Hey guys,

I am getting desperate here -currently using stock ROM-. I have been a big Xiaomi fan for a while now. Recently, I bought the Mi 11i to upgrade from the Mi 9T pro. It works well and all but there seems to be a problem with AR apps. Even though Google allows me to download the ARCore app(Google services for AR), no app with AR functionality works. I first noticed that when playing Pokemon go and every time I would tap on a Pokemon I got this Pogo screenshot. I have literally tried everything to get rid of it without any luck. Pogo support is terrible, their reply was practically an ad for their AR+ function. I have also tried to deactivate AR+ from the app's settings with no results.

If I understand the issue correctly, the Mi 11i does get proper AR support(hence why ARCore gets downloaded). However, there is either a problem with my device, or a recent firmware update broke the AR functionality(the official google list for AR supported devices does not include Mi 11i, but it does include the Redmi K 40). To confirm my suspicion and make sure it's not Pogo's fault, I tried other AR apps and they indeed do not work as per following screenshot Screenshot.

I have also tried using Xiaomi's feedback/log reporting function but I don't have high hopes.

If anybody can advise on this, I would highly appreciate it.
Last edited:


Jul 21, 2018
Anyone found a way to get ArCore services working?

Wysłane z mojego M2012K11G przy użyciu Tapatalka